2013



Results 1 to 20 of 20
  1. #1
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Carrier Ultra XL problems, need help!!


    Hello all, new here and im having some issues that i thought someone on here might be able to help me out.

    1st Amp gauge inside door is reading +40 all the time, i have changed alt. and battery and still no change.

    2nd im having an issue with it freezing up solid when i get a hot load on that needs to cool down(example), put a load of corn on that was fresh picked and iced down but was still pulping 55-60*, set unit to 40* unit froze up, set to 80* since manual def would not kick in, defrosted, set back at 40* 1 hour later froze up again, has been flashing "CD Sensor" on screen, just need to know what this means and where it is located, or even a part number.


    Thanks
    Site is great
    DD



  2. #2
    Join Date
    Jan 2008
    Location
    Texas
    Age
    55
    Posts
    132
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    Bad amp gauge most likely, if voltage is near 14 while running alt is OK

    Reefers are made to maintain temp. not pull down a "hot load"

    CD Sensor is Compressor Discharge Temperature Sensor, located on the compressor. Warning........if you aren't a reefer guy don't attempt to replace the sensor yourself.
    Last edited by DaButcher; 12-07-2010 at 03:11 AM.

  3. #3
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    579
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    Dabutch is right, unless you have some reefer background, I suggest you get help. Sounds like a possible high currant plug issues but....
    I doubt changing parts will get you out of this one.
    Is refrigerant level ok? Is defrost operation ok? What are defrost settings? What are the pressures? What is the "actual" amp draw/charge when running?

  4. #4
    Join Date
    Mar 2009
    Location
    Indiana, USA
    Age
    47
    Posts
    72
    Rep Power
    6

    Re: Carrier Ultra XL problems, need help!!

    I would say the ammeter is bad, not uncommon. You need to check the air switch, Klixon etc for the defrost problem. The CDT sensor is in the center head of the compressor on the left side. You will have to pump the compressor down to change it. Like the others said if you don't know what I am talking about, don't mess with it.

  5. #5
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    Yeah i know a little about reefers on what to mess with and what not to for sure, and as far as the unit being a temperatue maintainer i know that to, but it should have defrosted on its own especially set at 1.5 for defrost, i was just thinking the cd sensor was doing it.

    If the amp gauge is bad then why is it drawing everything out of the battery when it is off, once its off for 1 hour it doesnt have enough juice to start it, i have to jump off truck or leave cables on to keep it running. im at a loss on this one.

  6. #6
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    what would make it draw that many amps, i know the glow plugs will, and maybe starter, im gonna unhook GP completely in am to see if that is it.

  7. #7
    Join Date
    Jan 2008
    Location
    Texas
    Age
    55
    Posts
    132
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    Quote Originally Posted by Diesel Dummy View Post

    If the amp gauge is bad then why is it drawing everything out of the battery when it is off, once its off for 1 hour it doesnt have enough juice to start it, i have to jump off truck or leave cables on to keep it running. im at a loss on this one.
    In your original post you said amp gauge was +40. -40 and a dead battery in an hour is a different diagnosis. Glow plugs would be a good place to start.

    Will the unit manually defrost when box temp is at 40 or less?

  8. #8
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    yes it will DF at 40* or less, gauge is at +40 all the time, im assuming something is drawing on it all the time and kills the battery.

  9. #9
    Join Date
    Mar 2009
    Location
    Indiana, USA
    Age
    47
    Posts
    72
    Rep Power
    6

    Re: Carrier Ultra XL problems, need help!!

    If the gauge is at +40 that would indicate a charge. I would still say the gauge is bad. Most common thing I see on Carriers that drains the battery is the alternator.

  10. #10
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    I can understand the gauge is bad, but i seriously doubt that little gauge can kill the battery, or could it, like i said put new alt. and batt. in and no change, except now the alt. will keep it running with out being jumpered to truck. Still after its off not enough juice to start it. Im at my witts end with it, its ready for a new home and an TK put on, but its been flawless untill now, especially with 30K hours on it!!!

  11. #11
    Join Date
    Jan 2008
    Location
    Texas
    Age
    55
    Posts
    132
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    You are right the gauge will not cause the battery to discharge. If the connection on the back of the amp gauge is loose it will cause problems however.

    You need a inductive amp probe to help determine what is killing the battery. I would hook up the amp probe and start pulling fuses and relays until the amp draw stops.

    Relays are abbreviated for what they control. Example: GPR is glow plug relay.

    It is also possible that the battery is not getting charged correctly from the alternator.

  12. #12
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    579
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    Just to be clear here, is the battery dischraging when unit is off or on? Do you have a DC ameter? I'm interested to see were this goes. Don't give up on us yet!
    To drain battery or request 40 amps, its a short to ground somewere.
    Keep posting

  13. #13
    Join Date
    Mar 2009
    Location
    Indiana, USA
    Age
    47
    Posts
    72
    Rep Power
    6

    Re: Carrier Ultra XL problems, need help!!

    What does the micro show for voltage when it is running. If it is lower than normal (about 13.4) you may have a loose connection at the ammeter as stated before or another good place is the maxi fuse (80A) fuse holder. Also, did you put an OEM alternator on it or a local rebuild. It seems local rebuilders have a hard time rebuilding Carrier alternators. I take a lot of fresh rebuilds off that are bad. Try taking the pos. wire off of the alternator (with the unit off of course) If it sparks when you connect it, that is probably your problem.
    Last edited by Boss302; 14-07-2010 at 04:26 PM.

  14. #14
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    Quote Originally Posted by abbsnowman View Post
    Just to be clear here, is the battery dischraging when unit is off or on? Do you have a DC ameter? I'm interested to see were this goes. Don't give up on us yet!
    To drain battery or request 40 amps, its a short to ground somewere.
    Keep posting

    Yes it is discharging when off, ill try pulling relays in am when i get unloaded and get home, Alt. was replaced with a factory carrier unit, display says it is working fine shows between 13.4-13.8 at any given time. I got my wiring diagram to tell me where everything goes and what it is so ill guess ill try that.

  15. #15
    Join Date
    Nov 2009
    Location
    Canada
    Posts
    123
    Rep Power
    6

    Re: Carrier Ultra XL problems, need help!!

    With the unit off disconnect the battery then reconnect.....if it sparks you have a wire to ground or a bad starter or Alt.

  16. #16
    Join Date
    Jul 2010
    Location
    Willet,NY
    Age
    34
    Posts
    7
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    Ok, i do believe the amp gauge was bad and possibly drawing all the time, batter i threw in was worse off than the one i replaced, alt i believe was bad since after the new one it would run with no help from truck, so today i replace amp gauge(i could tap on it a put it anywhere i wanted once i had it out), and put a brand new battery in, works like normal now, will get new CD sensor and have my reefer guy replace it. So i thank you all for the help.

    Chad
    CMT Produce

  17. #17
    Join Date
    Mar 2009
    Location
    Indiana, USA
    Age
    47
    Posts
    72
    Rep Power
    6

    Re: Carrier Ultra XL problems, need help!!

    The ammeter can not drain the battery. Must have been a junk battery.

  18. #18
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    579
    Rep Power
    7

    Re: Carrier Ultra XL problems, need help!!

    Now stop talking about putting a TK on....Thats when you will have issues! LOL

  19. #19
    Join Date
    Jul 2010
    Location
    south carolina
    Age
    44
    Posts
    4
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    yep amp gauge no good..make sure your using at least 950 amp battery....second..yes load is hot...if you have a vent door in front and rear open up and drive down the road....it will take at least 12 to 24 hours to get close to temp..but on carrier...defrost wont kick in till temp is below 40...

  20. #20
    Join Date
    Jul 2009
    Location
    Greece Patras
    Age
    36
    Posts
    46
    Rep Power
    0

    Re: Carrier Ultra XL problems, need help!!

    A easy solution for the hot load is to change from the "fuction" the control brobe of the unit make it from REM BROBE to SUP BROBE and ALWAYS continoys mode .........

Similar Threads

  1. Replies: 12
    Last Post: 27-03-2011, 04:12 AM
  2. carrier screw compressor oil problems
    By redroge in forum Commercial
    Replies: 29
    Last Post: 03-02-2011, 08:35 PM
  3. Carrier 30XA Liquid chiller Problems
    By Ed Burris in forum Commercial
    Replies: 7
    Last Post: 13-08-2010, 08:12 PM
  4. carrier chiller hp problems
    By pobbo in forum Air Conditioning
    Replies: 2
    Last Post: 02-04-2009, 09:38 PM
  5. Carrier 551 problems
    By deu58 in forum Transport
    Replies: 11
    Last Post: 14-11-2008, 07:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •