});


Results 1 to 12 of 12
  1. #1
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    oil differential problems



    hi all i have a grasso rc 46 compressor from 2003 and it is keep falling out on low oil diff but i have plenty of oilpressure and suction pressure is altso ok and discharge temp is altso ok. but it have some cut out every 14 day

    i have changed the oil pressure spring and ball with no result

    oil pressure is 7.5 bar when running 50-100 % load and 11 bar under startup unloaded so oil differential ia 3-4 bar under load
    discharge temperature is 83 degres when running and suction pressure is 3.8 bar
    set point on chiller is -6

    and controller on this chiller ia a gea gsc simatic C7-633 controller from 2003 like compressor

    and compressor is running with Danfoss hvac drive min drive speed is 900 rpm and max is
    1350 rpm. and under startup it is running to max rpm and then going down to 900 rpm

    hope anyone can help
    IMG_3149.jpg
    IMG_6975.jpg
    Last edited by miz; 27-04-2019 at 08:55 AM.



  2. #2
    Join Date
    Nov 2009
    Location
    france
    Age
    59
    Posts
    148
    Rep Power
    13

    Re: oil differential problems

    Hi Miz,
    oil pressure 4 bar is differential pressure? if it's differential, it's high should be 2.5b at 50C
    at hi speed; 1470 tr/mn?
    what is your minimum driving speed?
    start and stop sequence is set by the GSC?
    you mean a GSC TP, with or without a data storage (how old is it)
    does it stop during normal operation or start/stop sequence?

  3. #3
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    Re: oil differential problems

    hello cricri

    start and stop sequence is set by my gsc controller and it has a memory card in the side for the program .

    i have added some info in my original post hope it is helpfull too make you understand my problem

  4. #4
    Join Date
    Nov 2009
    Location
    france
    Age
    59
    Posts
    148
    Rep Power
    13

    Re: oil differential problems

    so there is no logged datas on these GSC. min and max speed are OK. what is the oil diff pressure safety setting?

  5. #5
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    Re: oil differential problems

    the oil differential setting for low cutout is 1.0 bar and i can not see the high cutout in the controller

  6. #6
    Join Date
    Nov 2009
    Location
    france
    Age
    59
    Posts
    148
    Rep Power
    13

    Re: oil differential problems

    your oil pressure safety trip is too low and the oil pressure during normal operation is too high; but this is not the reason.
    suction and discharge oil filters checked or replaced?
    is a discharge temperature sensor fitted ?

    what can appen to these compressor is a failling capacity control mecanism. then discharge gas and suction are mixed and the discharge and oil temperature rise with a low oil viscosity.
    could be screw 14 or piston rings (10;5) on Pg 45 (IMM instruction and maintenance manual).
    try a monitoring of oil and discharge temperatures.




  7. #7
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    Re: oil differential problems

    what should the setting be on the low oil pressure trip.

    and yes there is discharge sensor mounted

    the oilfilter in the oil sump is brand new and the other one is altso brand new and the same goes for the oil reflo 68a.

    you could be right in this assumption with the screw and piston rings . one thing that i have noticed is that my discharge temp is not rising so fast as i want it to.

    could this be a indication on that the rings are gone on the capacity control.
    Last edited by miz; 27-04-2019 at 06:21 PM.

  8. #8
    Join Date
    Dec 2007
    Location
    australia
    Posts
    2,677
    Rep Power
    30

    Re: oil differential problems

    Miz,
    If a Grasso RC46 is the same as this in link on page 16 then 1.5 bar minimum oil differential.

    https://www.gea.com/docnav/Product%2...06/0089238.pdf

    Has machine been overhauled, or valves checked since installed on 2003?

    I thought on start up machine would be at minimum speed, load compressor, then ramp up speed!

    Can you prove unloaded function correctly, sump heater & oil return not returning liquid refrigerant after off cycle.
    Maldonado if machine shut down, does discharge pressure drop quickly, as could be valves or unloaded


    https://www.gea.com/docnav/Product%2.../PADOR9050.pdf
    Last edited by RANGER1; 28-04-2019 at 04:47 AM.

  9. #9
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    Re: oil differential problems

    i will correct the min oil diff setting to 1.5 bar

    mashine has been overhauled in 2018 november and new valves mounted at same time.before overhauling oilpressure was fine and no oil diff problems but we overhauled these loading mechanism and that is maybe giving us these problems today.

    mashine is running up too max speed with no load and then down to min speed after 10 sec to min speed and when reaching min speed 50 % load is put in and first after it put 100 % load on it will ramp up in speed

    sump and oil return heater is measured and they are function as they should and one way valve from oil return line is brand new and controlled and is working as it should so liquid ammonia going back to oil sump in compressor.

    mashine is loading an unloading as i shuld on both 50 % and 100 %.
    Last edited by miz; 28-04-2019 at 09:47 AM.

  10. #10
    Join Date
    Nov 2009
    Location
    france
    Age
    59
    Posts
    148
    Rep Power
    13

    Re: oil differential problems

    If there is no high discharge and oil temperature there is no problem whith the capacity control, it's a gas operated mechanism so no relation with oil pressure.
    are you sure that there is sufficient oil for operation at low capacity, poor oil return from evaporator and low level in oil sump.

    If this is OK, you should investigate arround your chiller for liquid suct by compressor.

  11. #11
    Join Date
    Jul 2011
    Location
    danmark
    Age
    40
    Posts
    19
    Rep Power
    0

    Re: oil differential problems

    what is the max oil temp on these i think that my oil temp is 60 degres under load and that is with brand new valves and no broken rings.

    maybe there is a slight mailfunction in my oilpump it is only coming periodic the oil diff alarm

    i have no liquid back to compressor for sure that is measured lots of time no cold suction line.

    for not so long a go we had the evaporator fixed with new plates and gaskets and we drained all oil from evaporator and we practicaly had the problem since then. could it be incuficient oil in evaporatator and oil return pot .
    Last edited by miz; 28-04-2019 at 07:18 PM.

  12. #12
    Join Date
    Dec 2007
    Location
    australia
    Posts
    2,677
    Rep Power
    30

    Re: oil differential problems

    Quote Originally Posted by miz View Post
    what is the max oil temp on these i think that my oil temp is 60 degres under load and that is with brand new valves and no broken rings.

    maybe there is a slight mailfunction in my oilpump it is only coming periodic the oil diff alarm

    i have no liquid back to compressor for sure that is measured lots of time no cold suction line.

    for not so long a go we had the evaporator fixed with new plates and gaskets and we drained all oil from evaporator and we practicaly had the problem since then. could it be incuficient oil in evaporatator and oil return pot .
    Miz,
    Grasso information indicates oil at bearings 10cst & above, depending on oil type.
    If you set to 70 deg C, I think safe, as Sabroe & other brands are 70 deg C.
    See page 23 of my second link.
    Maximum discharge temperature 155 deg C see page 5 first link as well as other important set points with loading etc.

    Maybe check pressure transducers for zero at atmospheric pressure & if they look like working properly, stable etc.

    Doubt oil pump problem if you can set to 3-4 bar when at operating temperature, but anything possible.

    Any high oil consumption issues?
    Last edited by RANGER1; 29-04-2019 at 08:48 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •