});


Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2017
    Location
    United Kingdom
    Posts
    2
    Rep Power
    0

    Unhappy Iveco Daily GAH Refrigeration Compressors Failing.



    Hi there. We are a charity and we have an ex-Tesco Supermarket Iveco Daily with a split system (fridge/Freezer) GAH Refrigeration SRD350MT. 179,000 miles on the clock. We have had problems with compressor failures.

    Purchased vehicle 24/04/17.
    Compressor Failed 24/05/17. Replaced compressor, suction filter, dryer. Checked system.
    Compressor Failed 05/06/18. Replaced compressor, suction filter, dryer. Checked system.
    Compressor failed 18/06/18. Replaced compressor, suction filter, dryer. Checked system.
    Compressor failed 29/06/18. Replaced compressor, suction filter, dryer. Checked system.
    Compressor failed 06/11/18. Replaced compressor, suction filter, dryer. Checked system.

    All but the first the units were replaced under warranty. Each time the standard procedures of checking the system for contamination, replacing the suction filter and dryer, adjusting the oil charge in the compressor to the manufacturers recommended, checking the operation of the hi lo switches etc.etc , were followed. on none of the occasions were there any significant signs of contamination. On two of the occasions the orifices were not just inspected but replaced. Each time there was still refrigerant in the system. We primarily used a local two man band company to do the installation each time, apart from one time when we used a larger refrigeration company and the condenser and a couple of valves were also replaced.

    Compressor has failed again! This time (which will probably be the last time!) we are sourcing the compressor from a different supplier to eliminate any batch problems). On this occasion the compressor is wet with oil on the outside and there is no sign of any contamination in the suction filter or compressor at all. And hardly any oil left in it. The original charge of the system was 1.7Kg and only 0.5Kg remaining. We will of course pressure test the system when fitting the Compressor.

    Does anyone have any ideas what is going on? We are fairly new to the Refrigeration Arena.

    Thankyou



  2. #2
    Join Date
    Dec 2010
    Location
    devon
    Age
    48
    Posts
    802
    Rep Power
    18

    Re: Iveco Daily GAH Refrigeration Compressors Failing.

    Lots to check but sea if this helps
    When comp failed what volume of oil was in the comp and colour of oil
    Are you fitting a qp comp
    What grade of oil comes with pump 32 48 68
    is st By comp hermetic or belts normally Tesco comp hermetic ie no belts
    What temps are you running
    When comps where fitted did anybody check body temp of comp during running
    when comps seize up the front seal burns thus possible refrigerant leak during seizure
    Your main clues will be with the old pump
    Most likely faults are wrong oil for temps being used
    Check valve on roof pod not seating allowing hot gas back suction line
    D f probe failing and unit staying on hot gas defrost to long
    running excess head pressure or flooding a comp but evap and comp are a long way away from each other so unlikely
    My one question is Tesco evaps are small 1.7 kilos on a twin seems a bit much
    Is sight glass black
    during testing after comp install was the unit put on defrost and if so did idle on I'veco drop heavily
    has the system got a muffler if it has had anyone checked its fitted the right way ta Charlie

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •