Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2009
    Location
    Inida
    Age
    41
    Posts
    1
    Rep Power
    0

    Freezer Fans Not Working



    Hi Friends,

    Just need help !

    Freezer fans are not working. There are 4 semi hermetic compressor. 1 is for freezer and 3 are for cold room. They share common condenser of 7 fans.

    1 Fan is working and 2 fan runs for a while and then stops.

    The evaporator coil is covered Ice on top half of compressor. So the freezer is not freezing properly. The Temp is showing around -11 C and it has set to -20 C.

    I have changed the Relay but no luck.

    Also, Suction pressure is around 6 psi and Discharge pressure is very high around 200 psi.

    I found Freezer Timer is not energized. But when i replaced it with new Timer and still it is not energized.

    I have attached Pics for your reference.

    Please send your suggestion friends.
    Attached Images Attached Images



  2. #2
    Brian_UK's Avatar
    Brian_UK is online now Moderator I am starting to push the Mods: of RE Site Moderator : and general nice guy
    Join Date
    Mar 2001
    Location
    Dorset
    Age
    70
    Posts
    10,671
    Rep Power
    52

    Re: Freezer Fans Not Working

    I assume that you mean that the condenser fans are not working which would be why you have a high discharge temperature.

    Has the plant been operating correctly before your arrival and has anything changed?

    You need to check the controls that operate these fans. Are they switched by pressure switches?
    Brian - Newton Abbot, Devon, UK
    Retired March 2015
    Please support http://the100project.net/Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •