Results 1 to 11 of 11
  1. #1
    Join Date
    Apr 2012
    Location
    united states
    Posts
    3
    Rep Power
    0

    Thermo King Spectrum SB mutitemp not cooling



    I've got a spectrum SB multi-temp SR2. Zone 1 is not cooling and I have almost no temp differential when zone 2 is on and in high speed cool when zone 2 goes into null zone 1 starts to cool good with a temp differential of about 4 degrees but as soon as zone 2 kicks back in my temp differential goes away and zone one starts to warm up. I have changed the hot gas solenoid in zone 1 already and this did nothing. with unit running in high speed cool in both zones suction pressure is high at about 75 psi and discharge is a little low at 200 to 220 psi. the unit passes a full pretrip and a unit running pretrip. any help would be greatly appreciated



  2. #2
    Join Date
    Feb 2009
    Location
    telford
    Posts
    2,096
    Rep Power
    27

    Re: Thermo King Spectrum SB mutitemp not cooling

    Have you tried pumping it down the compressor and if that pulls a good vacuum open up the suction valve and pump down via the reciever tank outlet,suction seems a little high and the delivery seems low to me.

  3. #3
    Join Date
    Aug 2009
    Location
    Turhona.libya
    Posts
    79
    Rep Power
    10

    Re: Thermo King Spectrum SB mutitemp not cooling

    is there any error code?

  4. #4
    Brian_UK's Avatar
    Brian_UK is offline Moderator I am starting to push the Mods: of RE Site Moderator : and general nice guy
    Join Date
    Mar 2001
    Location
    Dorset
    Age
    70
    Posts
    10,660
    Rep Power
    52

    Re: Thermo King Spectrum SB mutitemp not cooling

    Never mind the pressures, what's the refrigerant?
    Brian - Newton Abbot, Devon, UK
    Retired March 2015
    Please support http://the100project.net/Home

  5. #5
    Join Date
    Feb 2009
    Location
    telford
    Posts
    2,096
    Rep Power
    27

    Re: Thermo King Spectrum SB mutitemp not cooling

    ​my guess it will be 404a thats standard in thermo king

  6. #6
    Join Date
    Apr 2012
    Location
    united states
    Posts
    3
    Rep Power
    0

    Re: Thermo King Spectrum SB mutitemp not cooling

    The refrigerant is R404a
    It has no error codes and passes both unit running and nonrunning pretrip tests

  7. #7
    Join Date
    Feb 2009
    Location
    telford
    Posts
    2,096
    Rep Power
    27

    Re: Thermo King Spectrum SB mutitemp not cooling

    Did you carry out the pump down checks?

  8. #8
    Join Date
    Aug 2009
    Location
    Turhona.libya
    Posts
    79
    Rep Power
    10

    Re: Thermo King Spectrum SB mutitemp not cooling

    you mean the screen displays 00 code which means there is no fault.

  9. #9
    Join Date
    Apr 2012
    Location
    united states
    Posts
    3
    Rep Power
    0

    Re: Thermo King Spectrum SB mutitemp not cooling

    no codes at all, screen shows 00! I believe this is because the pretrip individually tests evaps one at a time so if zone 2 is in null and it is testing zone one it's going to cool fine the problem doesn't become present unit you run both zones in cool. and yes compressor pump down good and low side pump down shows good also. I've now checked all hot gas solenoids and liquid line solenoids in both zones for operation and opened them up to look inside could it be liquid return check valve? I would think you would start to get an iced up compressor if this was happening. and I have no indication of that happening

  10. #10
    Join Date
    Aug 2009
    Location
    Turhona.libya
    Posts
    79
    Rep Power
    10

    Re: Thermo King Spectrum SB mutitemp not cooling

    If all components are in good state and all setting parameters are in correct position as you said and also you are sure about the functionality of solenoids valves, expansion valves..ect .
    If you are also sure about the refrigeration charge in terms of mass (not pressure readings only) .it’s better you read the pressure from different spots (location at all zones) so that you can have a clear picture about system behavior when zone 2 kicks off .
    Last edited by Shibhrac; 19-08-2018 at 07:45 AM.

  11. #11
    Join Date
    Feb 2009
    Location
    telford
    Posts
    2,096
    Rep Power
    27

    Re: Thermo King Spectrum SB mutitemp not cooling

    Whats the ambient temperature?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •