Results 1 to 9 of 9
  1. #1
    Join Date
    Sep 2007
    Location
    Somerset
    Age
    63
    Posts
    4,505
    Rep Power
    38

    Danfoss Aks level Probe and EKC 397 level readings faulty.



    Hi Guys.
    I have a EKC 397 controller showing 0 level jn a surge drum.
    Despite the fact that liquid in the column can be seen.
    The m/A value read at U30 is just below 4 m/A hence the level display reading 0.
    Any ideas?
    I checked the cable connections at each end AKS 4100 to EHC controller.
    They appear ok.
    I wont be able to reply till this evening, but any help ideas would be appreciated.
    Grizzly


    Despite the High Cost of Living it still remains Popular!

  2. #2
    Join Date
    Jun 2011
    Location
    Australia
    Age
    37
    Posts
    291
    Rep Power
    14

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Oy vey

    Let me say, that I might know of someone, who has 7 of these - four have failed in 2 or 3 years..

    Some in the field might say, that when they unscrew the top cover & do the sniff test they can smell Ammonia within the head - conspiracy theory is that ammonia may track up through the coaxial gland and could perhaps possibly compromise the electronics

    Further, scatter-chart data shows majority of failures with (Ammonia) High Pressure & Medium Pressure applications. Use near 0 bar gauge seems to have had the least instances of failure to date - we can each make our own mind as to why that may be..

    Happy tinkering!
    Last edited by HVACRsaurus; 11-10-2017 at 07:54 AM.
    Mankind does not know why Coffee make us poop..
    https://m.youtube.com/watch?v=U8Fqyyv16SM

  3. #3
    Join Date
    Dec 2007
    Location
    australia
    Posts
    2,460
    Rep Power
    27

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Grizzly,
    Maybe you have this information already?
    Might help, not sure.

    http://files.danfoss.com/technicalin...4100_4100U.pdf

  4. #4
    Join Date
    Aug 2014
    Location
    UK
    Age
    69
    Posts
    402
    Rep Power
    16

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    As HV has said there have been many problems with the AKS 4100 hence the troubleshooting guide from Danfoss but it only tells you so much about the various software and manufacturing errors, but in my experience in 9 out of 10 cases it's a replacement probe needed. The early version AKS 41 went through several software and design mods and the latest version V4 was as good as gold but due to supply issues with the danish manufacturer Danfoss went to a French manufacturer for the AKS 4100 and the problems started up again .the old AKS 41 is now supplied via Parker a lot simpler and easier to set up in my opinion than the 4100

  5. #5
    Join Date
    Sep 2007
    Location
    Somerset
    Age
    63
    Posts
    4,505
    Rep Power
    38

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Thanks very much for your help and assistance Guys.
    It is very much appreciated, I will let you all know how it all pans out.
    Grizzly
    Despite the High Cost of Living it still remains Popular!

  6. #6
    Join Date
    Aug 2007
    Location
    Adelaide Australia
    Age
    63
    Posts
    538
    Rep Power
    17

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Hi Grizzly
    As HVAC has said they can leak ammonia up the cable where it fits into the head. All the ones we have installed have been the cable type not the coaxial type.
    We have had a few of the heads fail due to ammonia getting to the electronics, this was on a high pressure application. I think the epoxy used to seal the cable into the fitting does not fill the small gaps between the cable strands properly and this is where the ammonia leaks into the head. If this is the case the cable assy will have to be replaced, we have done that a couple of times.
    So far all the low pressure applications below 400 kpa have been good. All the ones we have installed are feeding back to a PLC.
    Regards
    Paul
    Born to fish, forced to work

  7. #7
    Join Date
    Sep 2007
    Location
    Somerset
    Age
    63
    Posts
    4,505
    Rep Power
    38

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Thanks Paul for your addendum.
    I will update you all some more tonight (Work calls!)
    I am leaning towards changing the whole unit now not just the head.
    The spirit of Magoo lives on as I know a lot of you where friends with him!
    Grizzly
    Despite the High Cost of Living it still remains Popular!

  8. #8
    Join Date
    Sep 2007
    Location
    Somerset
    Age
    63
    Posts
    4,505
    Rep Power
    38

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    It really brightens your day, when you get the kind of assistance that can genuinely come from one Engineer to Another.
    Especially when those guys can be on another continent.
    One closer to home and the font of most thing Danfoss. Glenn More deserves a special shout out.
    I have had some really sound advise from Him.
    So thanks Glenn.
    Brin, Geoff and Paul respect Guys.
    You are all what makes this forum great.
    Isn't it brilliant now that the boss is Personally checking New Posters!

    Ok basically this level control is on the side of an Ammonia LP surge drum of a Spiral Freezer System. The signal received by the EKC controller is then sent to the ICAD 600 unit to drive it open or closed dependant upon the relevant set points.
    Basic Stuff!
    Because of the demands upon the system and the revenues it generates, I am going to replace the level Probe and Head.
    Including a new HMI as the one I have is for the early software sys. Circa 2012. (When I fitted it replacing an old Hanson system)

    Hey on the bright side it means another trip to Cornwall and at least the roads are quieter now the holiday season has finished.
    Keep up the good work Guys!
    Grizzly.
    Rep point added where I am allowed!

    To those that did not receive one I have to spread the love around some more sorry!
    Despite the High Cost of Living it still remains Popular!

  9. #9
    Join Date
    Nov 2009
    Location
    france
    Age
    57
    Posts
    132
    Rep Power
    12

    Re: Danfoss Aks level Probe and EKC 397 level readings faulty.

    Danfoss-AKS4100-extract.JPG
    Hi to all,

    it's a well known issue from Danfoss in 2014.
    I've got the technical bulletin, attached a few lines which are matching with your comments.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •