Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2017
    Location
    United Kingdom
    Posts
    1
    Rep Power
    0

    Error 10 Thermoking Spectrum SL 2 50



    Hi,

    We have just purchased a used semi trailer with Thermo King SL 250 refrigeration unit.

    It works just fine on the engine, but when we select the 3 phase land line it gives error code 10. This is listed as Discharge Pressure High, but as it works ok on engine I'm thinking it may have another meaning. I have tried the reset button a number of times and checked for correct voltage in from the landline.

    Any ideas!!

    Thanks



  2. #2
    Join Date
    Sep 2010
    Location
    Dorset
    Age
    69
    Posts
    210
    Rep Power
    10

    Re: Error 10 Thermoking Spectrum SL 2 50

    Which host unit is fitted to the SL evaporator? This info is needed if you want help with host unit problems.
    Brian, retired in Devon.

  3. #3
    Join Date
    Feb 2009
    Location
    telford
    Posts
    1,871
    Rep Power
    24

    Re: Error 10 Thermoking Spectrum SL 2 50

    They have two HP switches one for road and one forvstandby check wiring to both switch's which are fitted to the compressor manifold ,disconnect both because ivdo not know which is which, and check if ones open circuit also check all fuses in control panel

  4. #4
    Join Date
    Feb 2009
    Location
    telford
    Posts
    1,871
    Rep Power
    24

    Re: Error 10 Thermoking Spectrum SL 2 50

    Where in the UK are you located?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •