Results 1 to 11 of 11

Thread: EKP cool

  1. #1
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    EKP cool



    20170824_101631.jpg20170824_101548.jpg

    Morning all.

    Has anyone had any dealings with these chillers?

    I'm getting an anti freeze alarm and it's a bit frustrating. Individually each circuit runs perfect however when both circuits run the anti freeze alarm pops up and stops the chiller.

    Looking at the diagram could it be possibly a low suction temp into the compressors? or perhaps a faulty sensor on the Evap?

    Help greatly appreciated



  2. #2
    Join Date
    May 2017
    Location
    Cluj-Napoca, Romania
    Age
    29
    Posts
    6
    Rep Power
    0

    Re: EKP cool

    I say it's a sensor problem. Sensors are usually poor quality in these models.

  3. #3
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    Was thinking along the same lines. Am you going to check the ohms of each one see what comes up. There's 2 for the heating water and 3 on the chilled side.

    You delt with these ones before?

    Thanks

  4. #4
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    One anti freeze sensor was 9.31 ohms and other was 8.78ohms so little bit of difference in resistance

  5. #5
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    Changed all sensors over from a working chilled and placed in one with faults. Still happening even though the sensors should be fine.

  6. #6
    Join Date
    Oct 2009
    Location
    england
    Posts
    175
    Rep Power
    12

    Re: EKP cool

    sounds like low flow rate,what are the inlet and outlet temps whats anti freeze setting whats temp setpoint

  7. #7
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    Hi Red.

    I changed set point to 14 with a differential of 2C to see if it may of been that issue but still continues.
    The water temps were 17.7 in and 14.6 out but this was before it stopped.
    I'd need to look at anti freeze settings on the controller as I'm not there now.
    Last edited by Stretch79; 25-08-2017 at 02:50 PM.

  8. #8
    Join Date
    Oct 2009
    Location
    england
    Posts
    175
    Rep Power
    12

    Re: EKP cool

    also check if there is an anti freeze stat fitted as well as the sensors for the controller

  9. #9
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    Thanks Red. There is apparently an anti freeze setting in the controller. Been told not to go as low at 3 degree. Also like you said it could be a lack of flow to the machine. Have to check strainers and if the pump is an inverter one or not

  10. #10
    Join Date
    Mar 2005
    Location
    u.a.e
    Age
    61
    Posts
    166
    Rep Power
    13

    Re: EKP cool

    Compare Ref. suction pressure of both circuits, Low on charge of one circuit may also possible to activate the Anti freeze.
    Also you are right a low water flow could be the cause, note down the water gauge pressures before and after to do any action.

  11. #11
    Join Date
    May 2017
    Location
    Essex
    Age
    38
    Posts
    34
    Rep Power
    0

    Re: EKP cool

    Thanks Malik55 it seems to be getting worse now. Bloody machines

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •