Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2017
    Location
    England
    Age
    52
    Posts
    8
    Rep Power
    0

    Mitsubishi Heavy Industries



    Model FDCA450HKXRE4A
    I'm getting a compressor start up fault on 1 of 2 compressors. Getting no voltage to the compressor although contactor pulls in. I've replaced the inverter pcb but still the same
    Any suggestions please??



  2. #2
    Join Date
    Feb 2011
    Location
    England
    Posts
    24
    Rep Power
    0

    Re: Mitsubishi Heavy Industries

    Have you checked voltage at the contactor? We need more info?

  3. #3
    Join Date
    Feb 2009
    Location
    telford
    Posts
    1,911
    Rep Power
    24

    Re: Mitsubishi Heavy Industries

    Sounds like a breaker in the control panel has tripped check the power to the contactor is this single or three phase?

  4. #4
    Join Date
    Jul 2017
    Location
    England
    Age
    52
    Posts
    8
    Rep Power
    0

    Re: Mitsubishi Heavy Industries

    Yes I have three phases across both sides of the contactor.

  5. #5
    Join Date
    Mar 2005
    Location
    u.a.e
    Age
    61
    Posts
    166
    Rep Power
    13

    Re: Mitsubishi Heavy Industries

    One of the Compressor is not working, which one, 1 or 2- What is the fault code?
    If you have voltage across Contactor then it means it is energized (or stuck permanently which you can check by turning power off, if still in then it is defective), Otherwise it is normal, all the safeties are satisfied and control is okay, then the fault is in the power module.
    You said that you have replaced the Inverter board, Is it a new one or removed from some ware, Are you sure that the board is okay, Also you have to check two other components mentioned as DM and PWB (which is a noise filter), I have not seen this unit and only refer from the drawing.
    It should be noted that you have to take extreme care wile working on electrical controls especially inverter type
    units, as there are capacitors in the circuit and have charge even power is switched off.
    Try to get controls manual and check accordingly.

  6. #6
    Join Date
    Jul 2017
    Location
    England
    Age
    52
    Posts
    8
    Rep Power
    0

    Re: Mitsubishi Heavy Industries

    Thanks Malik55. The fault code I am getting is E59. It's the no1 compressor. Yes it is a new inverter board.

  7. #7
    Join Date
    Mar 2005
    Location
    u.a.e
    Age
    61
    Posts
    166
    Rep Power
    13

    Re: Mitsubishi Heavy Industries

    Try to get service manual from the dealer, It is always good practice to follow what the manufacture said.
    Looks it is old model as service manual is not available by search,
    Compare both compressors winding readings, earth M-Ohms, Condenser fan motors and electrical power boards.
    If condenser fan FM01 1 has some problem may possible system will not come on. Also there are other Boards such as DM-1 (Diode Module), PWB (Noise filter), IPM(Intelligent power module) needs to be checked.

  8. #8
    Join Date
    Jul 2017
    Location
    England
    Age
    52
    Posts
    8
    Rep Power
    0

    Re: Mitsubishi Heavy Industries

    Ok. Thank you ��

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •