Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2006
    Location
    Hampshire
    Posts
    55
    Rep Power
    12

    Digital scroll issue?



    Hi chaps,

    Odd one here.

    We have 5 x Copeland digital scrolls on a site giving the exact same issue.
    These are the scrolls with the load / unload solenoid built into the side of the compressor and not external as on some.

    The compressors will not run on load, ie; solenoid de-energised. Suction & discharge remain the same.
    The solenoid valve itself was suspected, so we changed one on one compressor, but the issue remains.

    It appears at face value that the fixed scroll is stuck in the upper (unload) position.
    This being the case, does anyone know a procedure to get it to unjam / unstick? (if that's even possible) - or any other ideas.

    Anyone else had this issue?

    Thanks in advance.



  2. #2
    Join Date
    Feb 2009
    Location
    telford
    Posts
    1,909
    Rep Power
    24

    Re: Digital scroll issue?

    I had this issue a couple of years ago,I let it cool down someone else had installed it I found head pressure slightly high got more airflow over the condensor as it was in a warm environment, but I found the oil level to be low added oil and its ran fine ever since but that may not be your issue,luck was on my side that day I guess!

  3. #3
    Join Date
    Jan 2007
    Location
    India
    Posts
    60
    Rep Power
    12

    Re: Digital scroll issue?

    once I had similar issue in fixed scroll , I got the phase revered and run the scroll for a min then stopped the compressor and again corrected the phase by this time Scroll started working normally. But this issue I experienced was during commissioning stage

  4. #4
    Join Date
    Feb 2006
    Location
    Hampshire
    Posts
    55
    Rep Power
    12

    Re: Digital scroll issue?

    Apologies for the belated reply guys - been away.
    Reversing the compressor and then changing back was tried, but no effect.

    I'm pretty certain the issue is the top (fixed) scroll stuck in the up / unload position.
    Any other suggestions?, as there are a considerable number of these on the site.

    If this turns out to be a common issue with age, it could be quite a serious problem.
    If I find anything in the meantime, I'll let you know in case any of you chaps have the same.

    In the meantime, any other ideas would be welcome.

    Cheers

  5. #5
    Join Date
    Jan 2012
    Location
    Pakistan
    Age
    37
    Posts
    25
    Rep Power
    0

    Re: Digital scroll issue?

    DS.jpg

    Please find the attached file , most probably it will help

  6. #6
    Join Date
    Feb 2006
    Location
    Hampshire
    Posts
    55
    Rep Power
    12

    Re: Digital scroll issue?

    Many thanks buddy.
    This valve was replaced and the problem persists.
    I'm now in talks with Emerson technical. They have given me a couple more ideas which I'll try next week.

    I'll let you all know the outcome.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •