Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2010
    Location
    sydnry
    Posts
    2
    Rep Power
    0

    blocked LEV on Mitsubishi split system?



    Hey guys,
    just need some help on a Mitsubishi split unit im working on (MUH-A26WV).

    When the units on cooling it pumps down into a vacuum, looks like there is a blockage in the liquid line, I was thinking the LEV (Linear Expansion Valve) or strainer.
    BUT...

    When I put a magnet on the reversing valve it heats ok. If there is a blockage in the liquid line then it wouldn't work on cooling and heating?

    As soon as the unit turns off the suction pressure goes up to 20 bar quickly so it has plenty of refrigerant.

    below is the schematic diagram for the system,looks like when its on cooling and heating it goes through the LEV, capillary and strainer. That's why im confused it works on heating but not cooling? let me know if anyone has had experience with this issue.

    Thankyou

    mitsubishi.JPG



  2. #2
    Join Date
    Apr 2008
    Location
    Southampton, England
    Age
    43
    Posts
    926
    Rep Power
    29

    Re: blocked LEV on Mitsubishi split system?

    Had the same on Fujitsu units. EEV coil faulty and valve stuck closed but never have understood why heating was fine.
    Head has four coils inside, Mitsi should be able to give you the resistance readings.
    If you can hear it clicking on power up then coil and valve is fine, although remember there is a strainer there also.

  3. #3
    Join Date
    Aug 2014
    Location
    Australia
    Age
    30
    Posts
    68
    Rep Power
    5

    Re: blocked LEV on Mitsubishi split system?

    May be faulty EEV coil. As it works on heating maybe the EEV stays open and the system uses the capillary tube as the expansion device?

  4. #4
    Join Date
    Mar 2010
    Location
    sydnry
    Posts
    2
    Rep Power
    0

    Re: blocked LEV on Mitsubishi split system?

    Thanks for your help guys,
    I have the resistance readings from Mitsubishi and will check the coil this weekend.
    I guess it could also be the PC board not giving power to the coil but I think a fault code would come up if that was the case?
    Also if the coil was open circuit then i assume it was give a fault code too?

    Starting to think itís the actual valve that is stuck closed or one of the strainers but still canít get my head around why it works fine in heating if thereís a blockage in the liquid line?

  5. #5
    Join Date
    Jan 2017
    Location
    India
    Age
    26
    Posts
    5
    Rep Power
    0

    Re: blocked LEV on Mitsubishi split system?

    I am also facing this problem also got faulty system. Thank you for the help.

  6. #6
    Join Date
    Jul 2016
    Location
    Australia
    Age
    39
    Posts
    2
    Rep Power
    0

    Re: blocked LEV on Mitsubishi split system?

    Quote Originally Posted by carmine View Post
    Thanks for your help guys,
    I have the resistance readings from Mitsubishi and will check the coil this weekend.
    I guess it could also be the PC board not giving power to the coil but I think a fault code would come up if that was the case?
    Also if the coil was open circuit then i assume it was give a fault code too?

    Starting to think itís the actual valve that is stuck closed or one of the strainers but still canít get my head around why it works fine in heating if thereís a blockage in the liquid line?
    Check metering device in the Indoor unit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •