Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2016
    Location
    Pakistan
    Age
    47
    Posts
    10
    Rep Power
    0

    Frick Compressor Loading Problem



    Hi,
    I have three Firck Refrigeration compressor, I'm facing problem with standby compressor. When i started compressor lube oil pressure is not developing while lube oil strainer was also cleaned and moreover compressor is no developing any pressure while suction pressure is 1.5 bara. compressor is struck on 4% load position.
    Any suggestion for correcting this problem highly appreciated.
    NB: Compressor Model you can see in my other thread which is already discussed here.
    Toor



  2. #2
    Join Date
    Dec 2007
    Location
    australia
    Posts
    2,459
    Rep Power
    27

    Re: Frick Compressor Loading Problem

    Toor,
    Please make the following checks & see if improves

    - Correct oil level
    - Oil separator heater working & oil at least 30 deg C or more (very important as otherwise lots of refrigerant could be in oil). Has to be 10-15 deg C above ambient
    - pump running correct direction!
    - oil pressure regulators set correctly, may be 2, one on pump, the other off discharge of pump bypassing back into oil separator.
    - Bypass check valve around pump leaking if differential pressure oil fed when compressor up & running.
    - Pressure transducer reading & it's valve open
    - compressor should unload itself when off if unload solenoid energized, internal spring will unload it.
    - change main oil filters after pump if above checked out.
    Last edited by RANGER1; 08-10-2016 at 09:43 PM.

  3. #3
    Join Date
    Aug 2016
    Location
    Pakistan
    Age
    47
    Posts
    10
    Rep Power
    0

    Re: Frick Compressor Loading Problem

    Ranger1
    Oil temperature was 48^0C and oil pump suction strainer , filter was perfect before last shut down. even compressor was running on full load. But after few days we need to run it parallel and compressor is not sucking any thing as i reported in my 1st posting and not developing any pressure.
    Compressor slide valve struck on 4%.
    Hope you can better understand the problem.
    Toor

  4. #4
    Join Date
    Dec 2007
    Location
    australia
    Posts
    2,459
    Rep Power
    27

    Re: Frick Compressor Loading Problem

    Quote Originally Posted by Toor View Post
    Ranger1
    Oil temperature was 48^0C and oil pump suction strainer , filter was perfect before last shut down. even compressor was running on full load. But after few days we need to run it parallel and compressor is not sucking any thing as i reported in my 1st posting and not developing any pressure.
    Compressor slide valve struck on 4%.
    Hope you can better understand the problem.
    Toor
    Toor, is oil separator sump hot to touch by hand. Oil pump may have a gas lock in it causing cavitation? Can you somehow try to prime oil pump suction with oil or purge gas out to prime oil pump. What brand & model oil pump do you have?
    Last edited by RANGER1; 11-10-2016 at 11:33 AM.

  5. #5
    Join Date
    Jan 2017
    Location
    Canada
    Posts
    9
    Rep Power
    0

    Re: Frick Compressor Loading Problem

    Do you have a way to short circulate the oil when the pumps are on for an hour or so before trying to start the comp? We added a 1/4 inch needle valve on the high point to bleed of vapors. At the warmer temps we found the C3 in the oil was vapor locking the oil system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •