Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2014
    Location
    UK
    Age
    49
    Posts
    1
    Rep Power
    0

    display chiller not getting cold enough



    Hi, New here and couldn't find any ideas on this
    I have an igloo chiller display cabinet
    been working fine, but suddenly doesn't get cold enough
    The fan is working on the condenser radiator and it is clean and not blocked.
    Pipes into it hot, and out are cold
    pump appears to be working as hot and slight vibration felt
    but top condenser radiator part in chilled part, get frosted one end, but not cool other end
    is there a usual reason this may happen?
    I assume as the frost forms the coolant must be ok
    temperature is set to 2 degrees, i have checked, but cabinet wont go below 9 degrees now



  2. #2
    Join Date
    Apr 2008
    Location
    Southampton, England
    Age
    42
    Posts
    883
    Rep Power
    27

    Re: display chiller not getting cold enough

    Sounds (or should that be reads) sort of charge/restricted. Needs a chap with know how to confirm.
    Always worth blowing the condenser out with nitrogen / compressed air every so often as well.

    Cheers,
    Andy.
    Health and safety first..........unless I'm in a hurry.

  3. #3
    Join Date
    Apr 2006
    Location
    Not so sunny coast (BC Canada)
    Age
    35
    Posts
    1,646
    Rep Power
    17

    Re: display chiller not getting cold enough

    as said restriction or low charge, need to get a set of guages on it to know wich may be the case.
    Now in Redvers Sask.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •