2013



Results 1 to 12 of 12
  1. #1
    Join Date
    Dec 2010
    Location
    montreal quebec canada
    Posts
    6
    Rep Power
    0

    carrier supra 644


    disply panel shows eng oil
    changed alternator still the same



  2. #2
    Join Date
    Mar 2001
    Location
    Dorset
    Age
    66
    Posts
    10,041
    Rep Power
    40

    Re: carrier supra 644

    And ??????
    Brian - Torquay, Devon, UK
    I have to stop saying "how stupid can you be?" to my co-workers.
    They're starting to take it as a challenge...

    BASIC MAINTENANCE. If it doesn't move and it should then use WD40. If it moves but it shouldn't then use Duct Tape.

  3. #3
    Join Date
    Dec 2010
    Location
    montreal quebec canada
    Posts
    6
    Rep Power
    0

    Re: carrier supra 644

    sorry, the reefer won't crank. the fuel pump starts it's cycle and then the display panel shows eng oil alarm.

  4. #4
    Join Date
    Dec 2010
    Location
    montreal quebec canada
    Posts
    6
    Rep Power
    0

    Carrier Supra 644 Unit won't even crank.

    Display panel reads Engine Oil. Was told that it meant that the alternator was faulty, replaced the alternator still same alarm. Does anyone have any ideas what else could be wrong? The fuel pump begins it's cycle, and then the display panels shows the Eng Oil alarm.

  5. #5
    Join Date
    Dec 2007
    Location
    Melbourne
    Age
    43
    Posts
    279
    Rep Power
    7

    Re: Carrier Supra 644 Unit won't even crank.

    try re post this in the transport section.
    the fridge thinks its running as the alternator has power to the smaller positive wire, but has no oil pressure.

    So something is feeding voltage into the small positive wire, there are three wires on the Alternator, positive, negative and in the centre the smaller positive output that is excited when the alternator is turning.
    Take this wire off, then see if it starts, it will start, but the starter will stay engaged for way too long.

    Turn it off, then start tracing the fault on this wire.

  6. #6
    Join Date
    Dec 2007
    Location
    Melbourne
    Age
    43
    Posts
    279
    Rep Power
    7

    Re: carrier supra 644

    Quote Originally Posted by Brian_UK View Post
    And ??????

    c'mon Brian just move it to transport !!

  7. #7
    Join Date
    Oct 2001
    Location
    Nottingham UK
    Posts
    4,691
    Rep Power
    28

    Re: carrier supra 644

    Thread moved now
    I'm back on the Pale

  8. #8
    Join Date
    Dec 2010
    Location
    montreal quebec canada
    Posts
    6
    Rep Power
    0

    Re: Carrier Supra 644 Unit won't even crank.

    So I tried that still nothing different .Tried jumping oil pressure switch no luck unit now thinks its running
    and does nothing no code no alarm just runs fuel pump Any ideas
    thanks Mike

  9. #9
    Join Date
    Dec 2007
    Location
    Melbourne
    Age
    43
    Posts
    279
    Rep Power
    7

    Re: carrier supra 644

    check if theres power on the D+ terminal of the alternator with the fuel pump running. (the small positive), you'll then have to trace this wire back to the control panel and find out why it has power to it, I don't have a wiring diagram to do this for you as i'm at home and all my stuff stays at work.

  10. #10
    Join Date
    Dec 2007
    Location
    Melbourne
    Age
    43
    Posts
    279
    Rep Power
    7

    Re: Carrier Supra 644 Unit won't even crank.

    check if theres power on the D+ terminal of the alternator with the fuel pump running. (the small positive), you'll then have to trace this wire back to the control panel and find out why it has power to it, I don't have a wiring diagram to do this for you as i'm at home and all my stuff stays at work.
    Last edited by gravy258; 14-06-2013 at 08:34 AM.

  11. #11
    Join Date
    Dec 2010
    Location
    montreal quebec canada
    Posts
    6
    Rep Power
    0

    Re: carrier supra 644

    just found out that the buzzer in the control panel on the unit not the dash can short out and it gives the code causing all my problems thanks to another reefer repair guy.Disconnected the buzzer and now the unit starts.

    thanks Mike

  12. #12
    Join Date
    Aug 2011
    Location
    Canada
    Posts
    84
    Rep Power
    3

    Re: carrier supra 644

    Quote Originally Posted by mike69 View Post
    just found out that the buzzer in the control panel on the unit not the dash can short out and it gives the code causing all my problems thanks to another reefer repair guy.Disconnected the buzzer and now the unit starts.

    thanks Mike
    New one on me, Thanks for the follow up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •