Results 1 to 4 of 4
  1. #1
    Join Date
    May 2008
    Location
    malaysia
    Age
    33
    Posts
    82
    Rep Power
    10

    Daikin chiller trouble



    hi everybody.
    i have a Daikin water cooled chiller with dual circuit (dual 60hp compressor), one of the circuit
    not fully load. And i measure the system with FLUKE 52 Thermometer and the result is...

    system 1 - liquid line before expansion valve 51deg C.
    - after the expansion device 15.6deg C.
    - discharge pressure 280psi
    - suction pressure 80psi

    system 2 - liquid line before expansion valve 49.3degC.
    - after the expansion device 12.8deg C.
    - discharge pressure 250psi
    - suction pressure 66psi

    thanks for advice...



  2. #2
    Join Date
    Oct 2007
    Location
    manchester
    Age
    44
    Posts
    5,707
    Rep Power
    39

    Re: Daikin chiller trouble

    whats the model number

  3. #3
    Join Date
    May 2008
    Location
    malaysia
    Age
    33
    Posts
    82
    Rep Power
    10

    Re: Daikin chiller trouble

    i dont know the model, the info plate was gone, but i take a picture..
    Attachment 0IMG_1235.jpg

  4. #4
    Join Date
    Aug 2007
    Location
    Sydney
    Age
    45
    Posts
    1,093
    Rep Power
    17

    Re: Daikin chiller trouble

    Hi ah fai
    You need to give us more and do your homework, we will need you to search this forum and you will see you need to take a lot more measurements like all temps (including water in/out and condenser on/off) etc and pressures - crank, liquid, discharge etc. Make sure your thermometer is accurate. What refrigerant? R22. The photo shows frost on the compressor - is this now or a previous photo? Tell us what you know of the history of this system then others can search and find this thread useful.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •