PDA

View Full Version : testo 523 analyzer troubles







fri11j
14-09-2007, 02:44 PM
hi guys..
is anyone out there using the testo hvac analyzers?
I purchased the new model 523 kit and its lasted just over a week before it shat itself whilst adjusting superheat on a newly commsioned system.

one minute i was getting a temp reading from the clamp K thermocouple and then the temp reading suddenly dissapeared.. Either the thermocouple is faulty or the analyzer is faulty.
Im a little dissapointed but im hoping its a one off problem.
I have heard that there has been a few teething problems with the new 523-556 and 560 . has anyone else had any problems with theirs?

marc5180
14-09-2007, 05:28 PM
I wish i had enough money to afford to buy one of these guages. Should count yourself lucky.:(

kiwireeferman
19-09-2007, 01:12 PM
You should have brought the Digi-Cool analyzer.
Doesn,t look as flash, but built like a brick sh*t
house.

I understand the early versions had trouble with static, causing them to self destruct.

thermo prince
02-11-2007, 11:45 AM
hi Fri 11 J .... did u get any satisfactory answer from Testo or store where you purchased this? I am interested to know how these products are supported.
Should be warrantable I am sure? You said 1 week old when problem surfaced? Do we need a "tester for the tester tool" ?

There are several other posts on these digital analyzers and its of interest to know which is the all round best value for money deal out there ....

l'robot
02-11-2007, 05:30 PM
I looked at the 560 but were informed that due to manufacturing fault not now available untill mid 2008.

aldematt57
03-11-2007, 01:42 AM
I purchased the 523 in early summer and have had no problems of any kind with mine.
I'm very happy with the purchase which BTW, cost me 460 US dollars.