PDA

View Full Version : Cycle Stops at Low Suction Pressure







verstep
06-12-2006, 09:21 AM
We have split a/c unit, the brand is Carrier-a water cooled condenser, water from the water chiller scroll type of compressor. Just 1 month ago, I experienced low suction. I made leak testing from the evaporator to condenser but no leak found. I tried to vacuum the unit inorder to check if it is leaking nothing goes wrong. Everytime I charged refrigerant the pressure goes to 2.5 bar then slowly goes to 2 bar, then tripped. When I fully charge, the compressor stops it takes me time to bleed. I already changed liquid filter nothng happened. I adjust the flow of water from the condensing pressure of 14 Bar to 11 Bar, it seems it take long to tripped but still the pressure is reducing. I suspect that the evaporator pressure regulator or the compressor something doing this problem.

Can anyone share your ideas.

Renato RR
06-12-2006, 11:13 AM
TEV?Or NRV leaks.

Renato

kuuleun
07-12-2006, 06:02 AM
Hello everyone, I am just joint w/ this forum.
If unit use Thermostatic Exp. , the bulb sensor could be damage, I suggest to change TEV

Brian_UK
07-12-2006, 08:23 PM
Hello Kuuleun and welcome to the forum.

Rfcont
12-12-2006, 08:16 PM
...water cooled condenser

Pay attention to temperature of water it maybe too cold

Shakey
07-02-2007, 09:48 PM
What is the model number of the Chiller? The Electronic expansion device that is more than likely fitted on your machine is 1800 step. You can check the windings of the internal EXV motor by removing the cable and measuring the resistance across each of the five pins. You should measure aroung 32 ohms.

señorfrio
31-10-2007, 12:05 AM
If you have a solenoid valve may be this not opens totally