View Full Version : MTA Chiller Fault

12-09-2017, 09:21 PM
Hi Guys,
Called to a MTA chiller with both systems out on High Pressure switch. Its a R407C chiller with two systems.
No wiring diagram of course!

There are 4-off HP switches, two per circuit, one manual and one auto.
The switches are wired in series and there is 220V all the way through the switches. The HP relays are energised.

Here is the kicker.
I removed the fuse from the 220V transformer as I wanted to check wiring etc, put fuse back in and circuit one starts up. Look at the Carel controller, but still get an HP switch alarm on circuit two.
Just so I wasn't going mad, when the circuit stopped on temperature, I removed the fuse again, put it back in and Circuit two starts and circuit one is no alarmed on HP switch.
So now I am really going mad.

Anyway left it for tonight to see if I can find a wriring diagram.

Its a MTA AS319/N chiller.

Any thoughts?

There is another thread on here "MTA Chiller HP switch fault" with exact same problem, but looks like that issue was sorted with a fuse in the transformer.

12-09-2017, 09:54 PM
Hi chillermac
I am guessing but I would think your interrupting the power supply ( 3 pin reboot!) reset the HP Fault.

But I suspect that is exactly what you were thinking. I have seen it on older chillers where a drain on the Motherboard supply. Had the Chiller tripping on HP.

When what was really wrong was a solenoid coil was leaking to Earth and draining the control system voltage.

So a old high resistance contact on the transformer could well be the issue.

When I can access my archive I will have a look as to whether I have a wiring diagram for you.

Good Luck

13-09-2017, 07:06 AM
Good morning Grizzly and thank you for your reply. I also received your manual so I will have a look at it later this evening. Different site today...
Yeah its a strange one for sure. I use to get what you describe on the old Yorks years ago. Could happen on a transducer at a particular pressure and the transducer would then drag the voltage down.

Very difficult to know what is happening on the MTA. It is like it need the 220 V removed to clear the fault. Removing the 22V supply doesn't kill the power the controller, which is a PC0 Carel.

When I first got there and checked everything out, I did a hard reboot, but that did nothing. Only killing the 220 V seem to work, but that only clear the fault on one system.

Going to need to spend some time with it. Unfortunately the chiller is already second hand before this customer got it. In side the panel its like a total mess.

Funny enough, when he started it up last week, he reckons he worked fines for the first couple days, so this is a new fault.

13-09-2017, 02:56 PM
Possibly a latching type fault relay in there somewhere and pulling the 220 resets it.

13-09-2017, 08:50 PM
Very possible. Until they produce a wiring diagram, then I am snookered. The panel is a mess of red cables everywhere. This machine never got any love that's for sure.