PDA

View Full Version : 404A Walk in freezer issue







Trevor E.
02-09-2017, 11:58 PM
I've got a walk in freezer unit on board ship that's not coming down to temp. I've got 20 psi on the low side of the compressor, 280 on the high side. The comp/condenser is in the Engine Room where its about 110F. There's frost on the suction line and the sight glass is full. Any suggestions? Thanks!

RANGER1
03-09-2017, 01:33 AM
Trevor,
Pressures don't seem to bad, discharge a little high.
Check all fans are going
no ice on evaporator, should see all the way through with torch.
No product in front of evaporator, good airflow
door seal is sealing correctly.
If you have a good thermometer measure air on/ off evaporator.

Hot product put put in for some reason

Trevor E.
03-09-2017, 02:01 AM
19 F in, 18 F out. The box temp had gotten up to 32 but now is down to 27 F. I put a portable blower on the condenser after I blew out the coils with air. Evap coils are clean, no ice, good air flow. My walk in cooler is down (again)with a bad compressor so I'd cracked the freezer door a couple of inches and propped it open. We've done this on board a few times and the freezer unit has always maintained 20-25 F while keeping the cooler mid 40's. I'm off the coast of Thirdworldistan for a couple days until we go into port and I'm trying to keep the little food in the cooler from spoiling.
Thanks for the reply Ranger1

cadwaladr
03-09-2017, 03:13 AM
Off the coast of where?

Trevor E.
03-09-2017, 04:04 AM
Trinidad...

Guner Edip Riza
03-09-2017, 06:27 PM
Check your air flow through the evaporator or icing. Indications are that the evaporator is frozen solid.
On normal conditions you can not have a room temperature of 27F and air in to evaporator 19F.