PDA

View Full Version : Walk in freezer evaporator freezing up?







Ben23
27-03-2017, 07:32 AM
Hello everyone. I have been trying to suss out this zanotti ealk in freezer that the evap coil keeps freezing up on. Its not low on refrigerant but the evap coil on fan side is like a block of Ice. The suction line is froze as well as the top of the compressor and the capillary tube was frozen too it doesnt have a txv. I thought it was a defrost issue changed the defrost sensor and the controller for the unit with no joy. It quickly comes dowm from 10 to minus 2 then sticks amd starts to freeze up. I have no clue I normally work on systems with a txv.
The photos of the capillary its using after defrosting it all.

ICE/RUNNER
29-03-2017, 09:07 PM
Is it posible one of the distributor pipes could be blocked.

cadwaladr
29-03-2017, 09:32 PM
I have had issues with these,are you certain the controller is set correctly ie fan start temperature dripping time ,is the drain clear all these can give the symptoms plus are the fan/fans on the evaporator running to full speed is this unit a monoblock what make is it.

niceman
29-03-2017, 10:03 PM
I would guess that the evaporator is iced up, give it a good defrost, see if you get water to drain from it.The faces of the evap may have no ice on them, but have personally had an evap iced in the middle, reducing air flow and causing quick freezing of rest of pipework. Best of luck, hope you solve it

mbc
30-03-2017, 05:01 AM
hi
could tell what is your Gage pressure in both side
your tube is passing too much liquid
might you have too much refrigrant in system took it and check your super heat