PDA

View Full Version : Carrier Xarios Control Unit Conundrum!







Rich Green
08-03-2017, 05:36 PM
Hello

i'm really in need of help!

I'm a vehicle mechanic and I am currently working on a customer's Ford Transit.

The Transit has a Carrier Xarios refrigeration unit fitted with a little box on the dashboard to control the workings of the fridge.

The control worked fine (lit up and controlled the fridge) before I disconnected the wire to it so as to allow me to get behind the dashboard.

I have now re-connected the wire and no power appears to be reaching the unit, or at least it wont light up as it did before I disconnected it! I've made sure the ignition is on when I press the 'On' button but it refuses to display anything.

I have had the rest of the dash out in the hope it may be a wiring issue but I can't find an issue anywhere. I'm not a fridge mechanic and so the solution may be simple, at least i'm praying it is as I have to return the van to the customer at the end of the week!

Any help would be greatly appreciated. Just suggestions on what I may try would be wonderful, such as any fuses that I could check?

Should you require any further information then please let me know.

Thank you

Rich

cadwaladr
08-03-2017, 06:05 PM
Where in the UK are you ? I think I know what may be the problem,there is a fuse from the ignition to the unit on the roof along with a battery feed to the unit on the roof again that's fused close to where it connect to the battery supply,is this transit a panel van or a box type van?

charlie patt
08-03-2017, 07:13 PM
Is it ex Iceland ie carrier at back of van not up front

Rich Green
08-03-2017, 09:07 PM
Hi guys

Thanks so much for taking the time to reply.

The van is a panel van and it's not ex-Iceland. I'm located in Castleford, West Yorkshire.

cadwaladr - many thanks for the fuse suggestion. I'll have a look for this tomorrow and will let you know how I get on. I'm keeping my fingers firmly crossed that this cures things!


Thanks again

Rich