PDA

View Full Version : Trouble with a ***** system with hot gas defrosting







Rakesh
30-01-2017, 02:29 AM
Dear All,

We are facing some issues with a ***** ( R404a) system in a cold storage unit (-20deg C).

The compressor is a semi hermetic reciprocating type, make Bitzer.

While normal operation the discharge and suction pressure is 350psi and 50psi. The temperature is also OK.

But while the defrosting is on.the pressure for both discharge and suction is 100 and 80psi respectively.

The defrosting method here is hot gas type.

And while in this condition the liquid line is not getting proper heat to melt ice in Evaporator coils.

Kindly please look into this matter and help us.

Thanks.

RANGER1
30-01-2017, 05:36 AM
Rakesh,
Can you advise how many evaporators on this system?
Normally about 60% evaporators on cooling & 40% on hot gas defrost.
Without that you cannot generate hot gas.
Also evaporator on hot gas defrost has back pressure regulator set at about 10deg C (75psi),
Can you post piping schematic of system, sketch or something!

Tycho
03-02-2017, 08:55 PM
What Ranger1 said.

I am assuming the defrost/freezing cycle is controlled by automatic valves, going by the pressures you mentioned, it sounds like the suction/return valve is stuck in the open position and allows hotgas to go straight back into the suction/return line.

it would help to see a diagram or sketch of the piping and valves surrounding the evaporators for us to make more than an educated guess :)

charlie patt
04-02-2017, 11:34 PM
Are the condensor fans on fan speed control I've had issues on smaller rooms with hot gas df where no fan speed control and condensor fan stays on during df you build very little head and goes out on time not temperature fitted a fan speed controller defrost lovelly on the ones I've looked at but a plan would help