PDA

View Full Version : Scotsman ACM 45 Ice maker







najdo
20-01-2017, 08:02 PM
Hi guys, I am new to this forum. I want to ask for help, I have ACM 45 for repair, but it wont start. After I plug in to the power, only the green led is on (the unit is under power) and nothing more. I also checked all fuses, there are two 16A one from 500mA but they are ok. Also the switch is to position for cooling/operating.

Brian_UK
20-01-2017, 08:45 PM
Don't know the machine myself but have you followed the correct start up procedure?

Manual here...

https://www.google.co.uk/url?sa=t&source=web&rct=j&url=http://www.scotsman-ice.it/sitedocs/AC%252045-55%2520-%2520REV.%252006-2000.pdf&ved=0ahUKEwir9uf3ydHRAhUED8AKHYmJAhMQFggaMAA&usg=AFQjCNGYdWPMIZ6sKB7XLpBYZHt8xtDGew&sig2=VQsrf4q9ObqJ0pTZNBs7sw

najdo
20-01-2017, 09:54 PM
Yep I have tried that. Also to say, when I went to see the ice maker, he was working but it had problems with the defrost (the cubes were not falling in the container, probably damaged electromagnetic valve for bypass of the heat from condenser) so I took it home to repair it but when I plug it , it wont start.

nike123
21-01-2017, 08:51 AM
What is ambient temperature?
What is pressure of water supply?
Did you checked that there are no siphon at drain line.
Did you checked that water inlet solenoid valve is getting power?
Did you correctly adjusted operation selection switch on PCB to operation position according to instalation manual?
Did you checked that all connectors are firmly inserted to PCB?

najdo
21-01-2017, 12:12 PM
The ambient temperature and the temperature of the water is fine (those things with numbers are in the manual). Other things I checked and they are also fine, but I didnt checked the water inlet solenoid valve. I will do it now.