PDA

View Full Version : Samsung RSH1FTSW freezer and fridge too warm or random







sh99
27-11-2016, 12:32 PM
My fridge is out of warranty - quite curious because if I ask a simple question of Samsung they simply reply it is out of warranty and then point me to a bunch of totally untrained 'service partners' in France.
I have the full service manual btw. There are no diagnostic faults. Load mode usually shows that fans and things are running slowly. If I put it in forced mode it changes the fans but that is all. The compressor works fine. The temperature indications can be nice and low but in reality the internal temperatures are wildly different (-1bc in the freezer can be 0 or +3..).
I changed the evaporator cover in the fridge along with the sensors and heater.
I cannot get the fridge to be cold, the freezer is sometimes cold and the icemaker doesn't work. All this happened suddenly.

Since I can find no diagnostic problems, what on earth would a Samsung engineer do (assuming I can find one in France). Any ideas where I can go from here or should I simply bin it and buy new Chinese one?

sh99
27-11-2016, 02:58 PM
And another issue - the home bar door surround is very warm to the touch.

vikky1971
27-11-2016, 07:48 PM
My fridge is out of warranty - quite curious because if I ask a simple question of Samsung they simply reply it is out of warranty and then point me to a bunch of totally untrained 'service partners' in France.
I have the full service manual btw. There are no diagnostic faults. Load mode usually shows that fans and things are running slowly. If I put it in forced mode it changes the fans but that is all. The compressor works fine. The temperature indications can be nice and low but in reality the internal temperatures are wildly different (-1bc in the freezer can be 0 or +3..).
I
changed the evaporator cover in the fridge along with the sensors and heater.
I cannot get the fridge to be cold, the freezer is sometimes cold and the icemaker doesn't work. All this happened suddenly.

Since I can find no diagnostic problems, what on earth would a Samsung engineer do (assuming I can find one in France). Any ideas where I can go from here or should I simply bin it and buy new Chinese one?

@sh99, hi! there, how old is your fridge? It has to be frost free, I presume! Condenser must be at the bottom and forced cool type. How much gap have you kept behind the fridge?

sh99
28-11-2016, 07:46 AM
7 years old and has worked OK except it broke down twice in the first two ears under guarantee due to the defrost sensor problem. It is as far from the wall as it always has been - 25 cms.
WHy no errors on diagnostics? On load, why no high fan even under forced freeze (my mistake - I thought it did)? The ice maker machine works OK when I press the test button - drops ice and fills with water but no ice is produced automatically.
If I call a Samsung 'engineer' what is the guy going to do?

frank
28-11-2016, 07:37 PM
Have you carried out a full defrost with the fridge/freezer empty ..doors open and unplugged for at least 48 hours

vikky1971
29-11-2016, 05:17 AM
7 years old and has worked OK except it broke down twice in the first two ears under guarantee due to the defrost sensor problem. It is as far from the wall as it always has been - 25 cms.
WHy no errors on diagnostics? On load, why no high fan even under forced freeze (my mistake - I thought it did)? The ice maker machine works OK when I press the test button - drops ice and fills with water but no ice is produced automatically.
If I call a Samsung 'engineer' what is the guy going to do?

@sh99, now this you can do, plan and empty your fridge, clean it from inside, clean the condenser coils and keep the fridge door open for at least two days so that any frosted eporator coils gets free of icing.
This should solve your problem. All the best.

sh99
29-11-2016, 07:45 AM
I shall try this defrost for 48 hours. Why would this be different from the Forced Defrost mode though?
I'll Llet you know what happens!

sh99
29-11-2016, 10:43 AM
I just tested all the sensors on the PCB and they are all OK - reading about 7.2k ohms which corresponds to 60f roughly. Door sensors are all ok as well. Ice maker sensor is also ok. Forced freeze works fine. Lets hope this defrost works because I am a bit lost...

frank
29-11-2016, 04:33 PM
The forced defrost works on the evaporator sensor for termination which may restart cooling before the tunnel between the freezer and fridge has defrosted

sh99
01-12-2016, 07:41 AM
So, I just started the fridge. THe first thing I note is that the fridge temperature display says 6 centigrade and the freezer 16 centigrade. Both doors have been open for 48 hours. The room is at 13 so the freezer one is OK since I adjusted it in options to be 3c lower (?).
I'll leave it a few hours and then report again. The compressor fired immediately and I checked the capacitor (OK).
Just checked after 15 mins - fridge says 3c and freezer 12c

sh99
01-12-2016, 05:29 PM
One step forward, two steps back...
After it got to -20c for the freezer and 3c for the fridge I left it for a few hours and it seemed OK. Tried 30 minutes later and the freezer had melted. Did an auto-diagnostic and it said that the fridge had a defrost error and to test the resistance on CN70 between orange and white. I did - 5.4k ohms. Looking at the circuit diagram, this is the resistance of the fridge defrost heater in theory - except it measures 450 ohms and is brand new. AT least it is not blown.
Switched it on again and it took 5 minutes to decide to start the compressor - could be due to low ambient measurement though. This time the diagnostics show NO errors.
The manual I have is a bit odd. The description it gives is this:

Connector slipped out or open contact, wire cut or short circuited, defective thermistor or when it keeps heating during fridge defrost even after it does defrosting for 80 minutes.

What this means in English is anyone's guess..

Then the fix is 'disconnect CN70 from the main board and measure resistance between orange and white' - zero ohms is a heater short and infinite is wire cut or blown thermistor. I have 5.4k ohms...

I'm lost!

sh99
02-12-2016, 08:13 AM
After leaving it overnight, it still says it has a fridge defrost error. I rechecked the resistance of the sensor (8k) and the heater (350 ohnms) and the drain heater (10k). Nothing amiss here but it still won't cool

sh99
02-12-2016, 08:36 AM
Forget the last post regarding defrost error. No longer there. Still not cold though - far from it...

sh99
02-12-2016, 09:26 AM
I have the actual service manual for the fridge and the ONLY fault it has no section for is when the fridge it too warm!
If anyone needs it (FWIW), you can get it from elektrotanya.com

sh99
02-12-2016, 12:12 PM
Yes, it goes from worse to even worse...
When I put it in FF mode, it beeps for hours but there is no temperature change so this mode no longer works.
Please tell me this is something simple like the PCB broken?

BTW, for good manuals, try this

http://www.uncleharrywizard.com/NephewClub/wizardfrig/samsung

Reclaim Rag
06-03-2017, 06:27 PM
Gezzz sounds like a nightmare :(( best thing to do now is to check each wire one by one, sound like you have a broken wire or the harness has melted and fuse together ;$