PDA

View Full Version : Frick Compressor Loading Problem







Toor
08-10-2016, 05:25 PM
Hi,
I have three Firck Refrigeration compressor, I'm facing problem with standby compressor. When i started compressor lube oil pressure is not developing while lube oil strainer was also cleaned and moreover compressor is no developing any pressure while suction pressure is 1.5 bara. compressor is struck on 4% load position.
Any suggestion for correcting this problem highly appreciated.
NB: Compressor Model you can see in my other thread which is already discussed here.
Toor

RANGER1
08-10-2016, 09:34 PM
Toor,
Please make the following checks & see if improves

- Correct oil level
- Oil separator heater working & oil at least 30 deg C or more (very important as otherwise lots of refrigerant could be in oil). Has to be 10-15 deg C above ambient
- pump running correct direction!
- oil pressure regulators set correctly, may be 2, one on pump, the other off discharge of pump bypassing back into oil separator.
- Bypass check valve around pump leaking if differential pressure oil fed when compressor up & running.
- Pressure transducer reading & it's valve open
- compressor should unload itself when off if unload solenoid energized, internal spring will unload it.
- change main oil filters after pump if above checked out.

Toor
09-10-2016, 05:27 PM
Ranger1
Oil temperature was 48^0C and oil pump suction strainer , filter was perfect before last shut down. even compressor was running on full load. But after few days we need to run it parallel and compressor is not sucking any thing as i reported in my 1st posting and not developing any pressure.
Compressor slide valve struck on 4%.
Hope you can better understand the problem.
Toor

RANGER1
11-10-2016, 11:30 AM
Ranger1
Oil temperature was 48^0C and oil pump suction strainer , filter was perfect before last shut down. even compressor was running on full load. But after few days we need to run it parallel and compressor is not sucking any thing as i reported in my 1st posting and not developing any pressure.
Compressor slide valve struck on 4%.
Hope you can better understand the problem.
Toor
Toor, is oil separator sump hot to touch by hand. Oil pump may have a gas lock in it causing cavitation? Can you somehow try to prime oil pump suction with oil or purge gas out to prime oil pump. What brand & model oil pump do you have?

RichardB777
12-01-2017, 12:55 PM
Do you have a way to short circulate the oil when the pumps are on for an hour or so before trying to start the comp? We added a 1/4 inch needle valve on the high point to bleed of vapors. At the warmer temps we found the C3 in the oil was vapor locking the oil system.