PDA

View Full Version : carrier transicold model 50x truck unit







usa containers
19-09-2016, 07:17 PM
we have a couple brand new 50x units we've installed in 14' truck boxes.....

the units cool just fine but when the unit goes into a defrost cycle it floods / slugs the compressor and either kicks out on high head or "trips" the relief valve at the discharge service valve. the same thing happens during the heat cycle.

I have 2 brand new units with the same symptoms.

I've set the super heat and cpr valve. all the valves are energizing and working according to the manual.

anybody run into this before?

Brian_UK
19-09-2016, 11:20 PM
Non-return valve fitted in liquid line?

Cpr set in heating mode?

Also, I assume that you are using the correct R404a refrigerant.

cadwaladr
20-09-2016, 12:43 AM
The superheated should not make any difference the CPR valve should control the suction pressure hot gas is just pushed through the evap[porator are you certainly the CPR is set correct,is this on truck or electric?
we have a couple brand new 50x units we've installed in 14' truck boxes.....

the units cool just fine but when the unit goes into a defrost cycle it floods / slugs the compressor and either kicks out on high head or "trips" the relief valve at the discharge service valve. the same thing happens during the heat cycle.

I have 2 brand new units with the same symptoms.

I've set the super heat and cpr valve. all the valves are energizing and working according to the manual.

anybody run into this before?

IRMechanik
21-09-2016, 03:09 AM
Is the suction bypass valve closing. it bypasses the CPR, at 400 psi is should close.