PDA

View Full Version : whirlpool k40 icemachine no power to stat or solonoind







abp32
17-06-2016, 07:58 PM
hi all I am working on a k40 ice machine the ones with the heating grid . the problem I have is that there is no power to my cube size stat and consequently my water inlet solonoind I have traced the neutral back( red and blue wire) and traced what has to be the live back through the fuse on the back (which was fine) to the grid transformer terminal marked 0! the wiring diagram is long gone and I believe the tranny must feed the stat and solonoind does anyone have a wiring diagram for one of these as I cannot see why they would link the solonoind to a tranny I think I am chasing my tail .

Brian_UK
17-06-2016, 10:29 PM
Can't help directly, sorry but....

Try here..

http://www.whirlpoolk20.co.uk

Scroll down and click on spare parts for a wiring diagram.

niceman
18-06-2016, 11:16 AM
Try bypassing the bin stat and see what happens.

niceman
18-06-2016, 11:19 AM
If memory is right i think the tranny is only for the cutting grid.

Guner Edip Riza
18-06-2016, 01:03 PM
Try this site.

http://icemachinesireland.com/media/wysiwyg/pdfs/whirlpool/AGB024_K40.pdf

abp32
18-06-2016, 03:45 PM
yeah that's what I think but a wire leads off the back of the tranny directly to the stat that feeds the water inlet solenoid , the other wire is a neutral as I traced it back from the water pump neutral it makes no sense for it to be wired like that though ,nevermind if it's not that I have figured out a way round it (hopefully) .

abp32
18-06-2016, 03:47 PM
thank you everybody

Tayters
20-06-2016, 11:05 PM
Never has there been a more complex wiring diagram produced. Try this one, same diagram just laid out a bit different and makes a lot more sense.

Thanks due to Mr Nike123 who posted it once. :-)

cadwaladr
21-06-2016, 04:46 AM
Correct the wiring diagram which is on the machine somewhere is a joke,mind you ice machines or some of them are heath Robinson!