PDA

View Full Version : Urgent!! Manitowoc SD0422A Ice Machine Harvest Issue







Northdude
10-10-2015, 01:43 PM
Hey guys hope someone can shed some light on my issue as I am totally lost with this one ;(
Was called out to this machine as not producing ice. Found the machine going off on high pressure due to condenser fan pressure switch being faulty. Ordered and fitted new switch, vacuumed system out and weighed in correct refrigerant charge, fan cycling fine etc but when it comes to harvest the ice is failing to drop, it drops like 1 in every ten attempts.
The harvest duration is correct, hot gas solenoid is opening. I have weighed the correct charge in twice. During harvest suction pressure is at 75psi and high side is at 120psi. There just dosent seem to be enough head pressure to melt the ice. It states in the handbook that hot gas temp should be 65 degrees Celsius, I don't have a touch probe but have taped my standard probe to the hot gas line and the maximum I am getting is 34 degrees on harvest, the ambient in the room is around 11 degrees as its a cellar. The temp before and after the hot gas valve are the same so can't see it being a valve issue, the machine has been working fine the last 3 years in the cellar.

Really stuck with this one, seems the head pressure is just too low to melt the ice but have no idea why, any help will be great, thanks in advance ;)

Rtic
10-10-2015, 02:23 PM
Unlikely to be your problem; but when you weighed the refrigerant in did you use your gauges and lines? The charge is so vital with ice machines, that most manufactures ask that you use as short a hose as possible.

If I have the ice maker right, that ice should be dropping before the time limit kicks in; there is a magnetic switch that tells the PCB that ice has dropped and to start making ice again. Check the thickness of the ice, which needs to be heavy enough to be able to drop.

Rtic
10-10-2015, 02:28 PM
What refrigerent is this ice maker on? r404 or r134?

Northdude
10-10-2015, 02:54 PM
Hi rtic, yes the charge is 100% right, running pressures are perfect during freezing mode, yes the magnet is in the ice flap but the machine automatically starts a fresh cycle regardless of it being activated or not. It's on 404. I'm going back Monday, I will reclaim refrigerant, give it a deep vac and re-charge, will also fit a shrader valve to other side of hot gas solenoid to 100% confirm there are no restrictions, after that I can't think of anything else??

Northdude
10-10-2015, 02:55 PM
do you think the pressures on harvest cycle seem about right?

Rtic
10-10-2015, 03:28 PM
Sorry; I've removed this entery becuase I was getting my PSI to Bar conversion wrong.

Rtic
10-10-2015, 03:41 PM
Your pressures seem Ok

Read below from the manual of your machine

"Hot Gas Valve When the machine enters harvest the hot gas valve coil is energized opening the hot gas valve. Discharge gas is pumped through the hot gas valve directly into the evaporator. The evaporator temperature will reach approximately 40F (4.5C). The suction pressure during harvest should be a minimum of 70 psi (4.8 bar) for R404a units or 50psi (3.4 bar) for R134a units. The discharge pressure will drop during harvest."

Are you sure the ice is getting thick enough?