PDA

View Full Version : No oil seen in glass in compressor







forestcat
16-07-2015, 05:33 PM
I recently checked out one of my thermo king reefers . the unit is sb-310 . Unit was running and I didn't see any oil in a sight glass in compressor. I heated it up for 30 min and after put on cool high speed and still nothing. When i shut down unit and restart and unit was running at a low rpm on cool I noticed there is some drops of oil hitting the sight glass and the oil was barely seen in the bottom of glass. After the unit switch back to high speed no oil was visible . Should I add oil to it?

cadwaladr
16-07-2015, 11:48 PM
Quick answer is no,get it checked first question is if it's gone where's it gone? Quick test put it on a defrost cycle in fact put it on three and check the level when it's come off its defrost and settled five minutes.

forestcat
27-07-2015, 03:53 PM
Thanks a lot, will do that!

IRMechanik
28-07-2015, 03:33 PM
Get a light and look in the sightglass. Can be tough if the glass is fogged but you can usually see a reflection of the light in the oil. If it's just below the sightglass, you're ok. If you are down on oil, like Cad says where has it gone? The oil will usually migrate through the system and when running deep frozen some will get trapped in the evap but a defrost will usually bring it back. If you're leaking oil, you're leaking ***** as well so you'll need to get it checked out. The compressor holds about a gallon of oil, even half a gallon makes a substantial mess. You should see it.

forestcat
04-08-2015, 04:40 PM
Thanks a lot. I would try to do this.