PDA

View Full Version : TK sle Spectrum







sonkax
09-04-2015, 07:45 PM
Hello,

Can someone help me please with a service manual for these units?
No heating on 2nd zone. Only liquid solenoid energized. Some wiring diagrams can also be helpful.

Thank's!

tkjimmy
09-04-2015, 09:48 PM
if this unit is an sr2 the hgs2 circuit powers up the z2 hotgas solenoid, the second it does this it checks for amp drawls, if they are not in specs in stops sending power and sets a code.
if you can download the unit it will show the FLCT and a number next to it. that is fault current.
hgs2
flct 1.9 would mean its pulling 1.9 amps, the amps are 1.5 normal range is like .9 to 1.9 if it goes out of this range it will code out.

that is the simple way to diagnose codes on FET controlled circuits on thermoking units.

hope this helps

sonkax
11-04-2015, 04:43 AM
Hi,
It is uP-VI and only fault is check heat cycle after running for a while
LED HGS2 and SLS on relay board wont light up,
only LLS stays on. HGS1 closes, head pressure rises to to 25 bars,
and then it opens to release pressure.

gravy258
12-04-2015, 08:21 AM
how many remote evaporators does the unit have, is it plugged into the relay board correctly.
Are the jumpers in the correct place for evap configuration.
you've checked fuses and relays
is the micro sending the signal for HGS2
Do you have another relay board you can try

sonkax
13-04-2015, 06:35 AM
Hi,
Unit has 1 remote evap, it has an electronic module
on relay board. Opened up the module and i found
a mosfet burned. I guess that's the problem. Anyway
a wiring diagram would be helpfull. I don't have another , module at this time.

gravy258
13-04-2015, 10:22 AM
the I/O module.
http://www.filedropper.com/up-ivmulti-tempgreenbook
should help

sonkax
14-04-2015, 04:55 AM
Thank you very much.