PDA

View Full Version : SAB 151 E high oil temp trip







mostafaabdalla4
29-12-2014, 09:56 PM
Dear All , I have a problem in my units SAB151E , always trip high oil temperature before I drained the oil that accumulated in economizer and liquid receiver and charge oil , the level of oil is normal , no need to add more , the unit use for bakery as blast freezer , and it is not running continues what are the reasons which can cause this problem ? please I need your help

RANGER1
29-12-2014, 11:53 PM
What type of oil cooler do you have if any, water cooled?

Grizzly
30-12-2014, 04:49 AM
Hi mostafaabdalla4
Ranger1's question is completely relevant as dependant upon what type of cooling you have.
Greatly affects oil operating temps and their control settings.
Also how your Comp is set up to load up and down could be an issue?

What is your oil temp cut-out set too?
Grizzly

Magoo
30-12-2014, 07:13 PM
If you have a thermo syphon oil mounted below liquid receiver then the oil cooler has oil in refrigerant circuit as well.
Reason for high carry over to system possibly compressor load rates too fast during pull down of blast freezer.

josef
02-01-2015, 10:30 AM
Adjust the valve no.123 injection of oil on the rotor.

mbc
08-01-2015, 02:57 PM
Hi mostafa

you wort your oil temp is high, why you changed the oil ? what is the reason for that?

you have to look for oil cooling system ( water -- thermo syphon --air ) also check the ECO system and also liquid level in system and filters in ECO. line