PDA

View Full Version : Help?!







Hayden Baird
28-12-2014, 12:02 PM
Hey guys I have an open front bottle cooler that I'm working on, it is not cooling, compressor is running, refrigerant is at correct charge and all fan motors are running.
Is this an expansion valve issue?

Any input would be great.

I have new expansion valve but want to get a second opinion before I fit new one. Need advice ASAP. Thanks.

Hayden.

Hayden Baird
28-12-2014, 12:03 PM
Temp is also up around 22degrees C

install monkey
28-12-2014, 12:33 PM
cond coil clear?
comp pumping?
adjust txv

monkey spanners
28-12-2014, 02:53 PM
How have you confirmed the refrigerant charge is correct if the system is not cooling?

For a underfeeding TEV you would expect to see a lower than normal suction pressure, a lower than normal head pressure and excessive ice formation on the TEV and possible the first part of the evaporator circuit (though defrosts may clear this)
It can be underfeeding due to incorrect adjustment (unlikely in previously working system), the sensing bulb could have lost some or all of its charge making the valve shut down, or the inlet filter could be blocked.
A blocked drier or failed solenoid can give similar symptoms as could mechanical damage to pipework.

http://www.danfoss.com/nr/rdonlyres/2c22fd41-9e7f-400d-ad7b-6b990e866dc5/0/pf000a102.pdf

MikeHolm
28-12-2014, 04:08 PM
Good document. I'd spread the love but it seems someone thinks I don't have enough to go around, haha

PaulZ
28-12-2014, 09:35 PM
Hi Hayden
There are many reasons why the fridge is not working, inefficient compressor, blocked drier, faulty TX, short of refrigerant, blocked condenser, iced evap to name a few.
A bit more info would be helpful.
The Danfoss link should help you sort it but if not give us some more info.

Regards
Paul

Magoo
29-12-2014, 12:07 AM
Did you charge system in liquid phase or vapour phase. ?

mbc
31-12-2014, 04:54 PM
you wort comp. is running ,

do you have heat on pipe goes to condenser and do you have cold on pipe is coming from evap.
might one of your valve plate is broken and your comp. does not do any compress
to understand you have to check your inlet and outlet pressure on the compressor .
from that you will find the efficiency of compressor and also from touch of drier inlet and outlet of drier if there is different temp you will find is blocked and you have to change it .

if you see the TX valve you will find is it working or not

mike live
17-01-2015, 01:29 AM
is this an open case deck ? - / an open integral fridge. maybe the obvious but is there an air replacement issue. i.e. an ac blowing into the cabinet or next to an entrance door?