PDA

View Full Version : chiller on/off temps







WCEbloke
19-09-2014, 05:41 AM
Hi, I'm working on a brine chiller at a winery, the the setpoint is at -3c. Its a tube evap the brine in is at -2.5c brine out at 0.7 c. Ive not worked on these before. I would have thought the brine out should be at a lower temp, I tried swapping the sensers with the same result. Any advice please?

Brian_UK
19-09-2014, 10:19 PM
It looks like your evaporator isn't working if the brine temperature is going up not down.

install monkey
19-09-2014, 10:30 PM
has the brine circulating pump been replaced? is it's direction correct? any hero sparkys reversed phase on the pump?

WCEbloke
20-09-2014, 12:06 AM
I confirmed the correct dierction by seeing the brine enter the holding tank. Also check the the system is bringing the brine down to temp ok. After trying head transfer paste as it had none on it, I still couldn't get the brine out temp readout, (b1 on the carel i33) to what it actually was. I decided to leave it as the compressors were cycling off b1brine into the evap anyway, so the b2 didn't appear to affect the performance. Thanks guys.

Grizzly
20-09-2014, 11:33 AM
Hi WCE Bloke.
Welcome to the forum.
I suspect you have answered your own question here!
If the chiller is controlling on Water on the chiller (RWT) then what you are getting is correct.
Can you advise what chiller it is?
Or at least what make and model the controller is?
Also can you swap control to water off (LWT)
Also have a look at the chilled water circuit strainers, a reduced flow through the evap would exasperate the situation.
Good luck.
Having re-read your original post then I would check out the KPA across the evap because it sounds like a potential flow issue?
Grizzly