PDA

View Full Version : Frick RXF Unt has a problem with its XJF 120 compressor Unloading.







mahmoud4871
30-08-2014, 10:30 AM
Hello Everyone.
I am facing a problem with XJF 120 Compressor as it loads perfect but once it load above 75 or 80 % of the FLA and we try to unload it manually or even Auto it never unload.
Unless I stop it while it is at 100% FLA, the slide goes to 0 position. Or I enter the capacity calibration screen and press unload capacity then it works and slide valve start moves to unloading position.

The following are the unit Data and operation parameters:


1- Suction Set point 68 Psig.
2- Discharge operating pressure up to 230 Psig.
3- Oil Pressure always 4 to 8 psid below discharge pressure due to oil filter differential.
I have replaced the loading unloading solenoid block with a new one also replaced a complete service seal kit for the slide piston including the NRV.
Checked the loading unloading solenoid for activation found working fine and receiving signals.
Calibrated the slide valve many times without any results.
But the only thing I noticed that the slide Stop position reading is not moving always on 2.2 which I donít understand.
By the way this phenomena of unloading problem is existing in two compressor units working on the same suction settings. And the two compressors are new installed.
Kindly if anyone here has an idea or faced this problem before he may advise what to do.
Thanks and BR
Mahmoud

RANGER1
30-08-2014, 11:59 AM
mahmoud,
Have you checked both Vi solenoids are energized to give you 2.2 Vi setting.

Can you check needle valve on slide valve is open enough.
Manual states should take minimum 30 seconds to load or unload if given a constant signal.

Also oil filters, when were they changed last, may be due.
Check & let us know.

Grizzly
30-08-2014, 12:14 PM
Hello Mahmoud.
Could you advise as to what type of Controller you have fitted?
How many comps are linked?
Plus why are you trying to load and unload around the FLA?
What control reference are you working with?
A milliamp or Suction SST would surely be more relevant?
If you can elaborate what is the problem "We" may be able to help further.
Personally I am not understanding what you are trying to achieve (Yet?)
Grizzly

mahmoud4871
30-08-2014, 05:07 PM
mahmoud,
Have you checked both Vi solenoids are energized to give you 2.2 Vi setting.

Can you check needle valve on slide valve is open enough.
Manual states should take minimum 30 seconds to load or unload if given a constant signal.

Also oil filters, when were they changed last, may be due.
Check & let us know.

Actually I did not suspect the Vi Solenoid and did not checked yet.
I checked the Needle valve and found it opened enough,
Yes Oil filter I replaced it and the DP across the filter is about 4 to 8 PSID.
Please have a look on the attached photo.

11739

mahmoud4871
30-08-2014, 05:10 PM
Hello Mahmoud.
Could you advise as to what type of Controller you have fitted?
How many comps are linked?
Plus why are you trying to load and unload around the FLA?
What control reference are you working with?
A milliamp or Suction SST would surely be more relevant?
If you can elaborate what is the problem "We" may be able to help further.
Personally I am not understanding what you are trying to achieve (Yet?)
Grizzly

It is Quantum LX
Compressor when it loads to 100% it never unload again auto even if the suction pressure below the set point. or even if we try to unload it manually.

Grizzly
30-08-2014, 06:09 PM
Ok. Mahmoud.
Thanks for the update.
You have me foxed that's for sure.
Historically I had a similar situation and was able to prove the slide operation with Nitrogen.
By disconnecting the slide oil feeds at either end and then pressurising either fitting.
You have to be careful of the surplus oil that drains out though.
Once I had proven that the slides physically moved I replaced the relevant solenoid block.
Which solved the problem.
You use the term loading unloading solenoid block. There are 2 blocks one lets the oil into the relevant end of the slide piston. The others bleeds away the oil at the opposing end.

So if you are pushing at the return slide end the opposite end should allow the oil at that end to be drained away. Just a thought! it may just be worthwhile proving the mechanical operation of the slide through its valves.
Because the piston unloading spring will naturally take over at the comp stops as the oil pressure forcing the slide open drops off, you will find the slide returns when the comp is turned off!
Grizzly

josef
30-08-2014, 09:02 PM
Check valve slide valve.

Josef.

RANGER1
30-08-2014, 11:11 PM
mahmoud,
Is the compressor a XJF120S
Can you post a few pictures of unloader end solenoids & Vi solenoids.
You say it's happening to 2 new machines?

RANGER1
30-08-2014, 11:32 PM
Check valve slide valve.

Josef.

Can anyone explain what this internal check valve is for?
Is it when machine turns off it unloads?
Does discharge pressure then prevent it unloading.

serviceman
09-09-2014, 11:05 PM
will have the ability control programming submenu

kiwi
24-09-2014, 02:39 AM
Do you have the old slide potentiometer or the later linear transmitter?
Remove the cover if is the old pot style and watch the rod move to prove it is not a transmission error. The old pots were also prone to having "holes" in the range and would give a poor reading. FLA should show this though. I once had a 151 where the indicator rod would stick as well showing loaded when not true.
The compressor appears to unload correctly when stopped under spring pressure so does not sound mechanical, and the fact you can force it unloaded in the calibration screen suggests all is OK from an electrical perspective. FYI just use the slide up/down buttons on the panel to do this. It's much easier.
The check valve is to drain the load cylinder when at rest and allows the unloader spring to do its job.
Are you making sure calibration is being performed at 2.2Vi? as this will give error too.
You are using Automatic calibration or Level 3 manual calibration?
Your proportional values in Mode setup could be too little to give enough of a unload pulse for the piston to react. Large Dead Band or Proportional band may inhibit unloading?

kiwi
24-09-2014, 02:44 AM
Can anyone explain what this internal check valve is for?
Is it when machine turns off it unloads?
Does discharge pressure then prevent it unloading.
Correct. The Frick hydraulic cylinder is open to discharge on the non hydraulic side. OP < DP running = no relief.

mahmoud4871
23-11-2014, 06:42 PM
Hello Everyone.
Thanks very much for your ideas, Actually I tried everything, I noticed that the Slide Stop is one which is not moving at all. but I tried something not logic and it succeeded.
Despite the Unit is RXF and the compressor is XJF 120.
I changed the selection to RWF IN THE COMPRESSOR CONFIGERATION SCREEN. and it works find both slide valve and slide stop now loading and unloading.
Its really strange and still cannt understand why,