PDA

View Full Version : Duopack gea il problem







cdelefor
05-08-2014, 01:01 PM
We suffer with oil carry over (a lot > 150l) from our DUOPACK GEA compressors (2 screws on 1 simular oil separator). Anybody the same (bad) expirience with this kinds of Duopack? 1 compressor is fixed speed, 1 with inverter. On NH. Minus 40 / +35C. OIl Petro Canada Reflo 68A. Like to see a Duopack working without this oil problems, without success so far. Thanks in advance. Carlos.

RANGER1
05-08-2014, 09:35 PM
cdelefor,
Not sure if they are exactly the same, but they do have occational problems here in Australia.
There is a supposedly more efficient oil separator out now indicating 5ppm ol carry over.
The ones I have seen have a large number of small filters in a circle using "0" ring to seal on ID of filter.

How long have your coalesces been in service?
If reasonably new, sometimes "0" rings do not seal & have made rubber gaskets to seal on end faces of each filter.

Grizzly
05-08-2014, 09:51 PM
Hi cdelefor.
Ranger is on to something there.
When I first read your post I thought of a Sabroe pack that threw oil over for a pastime!
The cause turned out to be a poor O-ring seal on one end of the coalescer.
With a new Filter the oil carry over stopped over night.
So what's stated could be very relevant.
Grizzly

cricri
08-08-2014, 12:02 PM
Hi cdelefor,
what type of compressor is it, medium? large?
are they fitted with suction check valve (new design) or not?
what is your minimum driving speed with inverter together with minimum slide valve position?