PDA

View Full Version : Carrier xarios 500







TransCool
22-04-2014, 10:04 PM
Got a box running as a freezer on standby only, road compressor blanked off.
When on defrost suction pressure is 2.6 bar but intermittently it rises to 8 bar and cuts out on hp2 switch
Any ideas what could cause this ?

moggy66
23-04-2014, 12:41 AM
Got a box running as a freezer on standby only, road compressor blanked off.
When on defrost suction pressure is 2.6 bar but intermittently it rises to 8 bar and cuts out on hp2 switch
Any ideas what could cause this ?


is the condenser fan running and at the right speed?

IRMechanik
23-04-2014, 03:27 AM
Got a box running as a freezer on standby only, road compressor blanked off.
When on defrost suction pressure is 2.6 bar but intermittently it rises to 8 bar and cuts out on hp2 switch
Any ideas what could cause this ?


What's your discharge pressure running?
2.6 bar is the cpr setting. If the xarios 500 is the same as the NA 50x there is a bypass circuit around the CPR. When the discharge pressure rises above 27.5 bar HP4 will close, closing the bypass circuit and brings the CPR back into the system and should lower the discharge pressure as well as the suction.
HP2 switch should cycle the fans on and open the condenser inlet solenoid at about 22 bar at 30 bar HP3 will trip and shut the unit down.

Is the charge weight correct?

TransCool
23-04-2014, 07:34 AM
Condenser fan runs and cycles on pressure switch, new motor fitted 2 months ago .there is no by pass valve near CPR only a liquid injection valve
On defrost when operating correctly head pressure sits around 11bar and suction 2.6 bar, when fault occurs head pressure rises to approx 21 bar and suction climbs quickly to 8 bar and above, unit trips pressure switch dropping pressure does this 2 or 3 times during defrost until it terminates defrost on temp and not time
Fitted new standby compressor last week ,changed drier vacc end out overnight and new charge of gas weighed in,unit cools fine

cadwaladr
23-04-2014, 08:40 PM
Why did you change compressor,maybe some **** gone into system,time to strip down upstream from compressor delivery

TransCool
23-04-2014, 09:07 PM
Why did you change compressor,maybe some **** gone into system,time to strip down upstream from compressor delivery

Unit was tripping mains supply , dead short inside compressor, drained oil on old unit and oil was clean
If condenser solenoid valve was leaking could gas come back through oil separator and into compressor via oil return line from separator ?

sonkax
24-04-2014, 04:49 AM
Condenser valve leaking will not trip any switches only low heating capacity, hot gas valve leaking would be a problem, oil separators usually will fill up with dirt and not let oil back to compressor it's a must change when road comp fails, never heard of one letting hp back into suction... If used only on stby i would remove injection valve from circuit. Do you have 8 bar on suction after stopping or during operation?

TransCool
24-04-2014, 07:35 AM
Condenser valve leaking will not trip any switches only low heating capacity, hot gas valve leaking would be a problem, oil separators usually will fill up with dirt and not let oil back to compressor it's a must change when road comp fails, never heard of one letting hp back into suction... If used only on stby i would remove injection valve from circuit. Do you have 8 bar on suction after stopping or during operation?

Suction pressure only rises to 8 bar and above on defrost builds up slowly then after about 6 bar rises quickly
Going to attend today and fit solenoid valve repair kit , will keep you guys posted
Thanks for all the help

sonkax
25-04-2014, 04:32 AM
More likely it's the CPR. Put unit on heat and try changing the cpr settings, measure vap inlet and outlet press , see if messing with the cpr changes anything on suction side.

TransCool
04-05-2014, 10:04 PM
Fitted new CPR and repair kits to solenoid valves,Unit has been fine for a week now and all ok
Thanks for all the help