PDA

View Full Version : Screw compressor







Theboy
11-03-2014, 09:00 PM
Have got a York screw compressor it's a dxs36lasa46/50 problem I have got is when it gets up to full speed the compressor gives off a high scretching noise which is very loud haven't got much experience with York chillers would welcome some advice.

install monkey
11-03-2014, 09:04 PM
high screetchin noise when it stops- non return valve not seating- rotors run backwards as pressures equalize

Theboy
11-03-2014, 09:15 PM
The scretching is when the the compressor is running tho but when it starts up it is fine only starts this noise after a few hours if this helps

install monkey
11-03-2014, 09:24 PM
obviously oil pressure is ok- prob worn bearing- check the running hrs and when it was last serviced

TF12
11-03-2014, 10:01 PM
You're not dumping liquid on it are you?

Josip
11-03-2014, 10:53 PM
Hi, Theboy :)



Have got a York screw compressor it's a dxs36lasa46/50 problem I have got is when it gets up to full speed the compressor gives off a high scretching noise which is very loud haven't got much experience with York chillers would welcome some advice.

probably gets up to full capacity ....




The scretching is when the the compressor is running tho but when it starts up it is fine only starts this noise after a few hours if this helps

so after few hours of running there is coming liquid refrigerant into suction like TF12 conclude in his post ...

It is not easy to give some good suggestion,
because we do not know anything about your plant ... try to give us more data ...

Best regards, Josip :)

TF12
12-03-2014, 02:30 AM
For example:
Refrigerant. Compressor application/Process application. Suction pressure and suction superheat. Discharge pressure and temperature. Slide valve position. Motor amperage. Refrigerant level in vessels ie receiver, accumulator/inter cooler/surge drum, expansion valve type....
Screeching is not normal and if the compressor sounds like it is in distress, it probably is.
In all seriousness I had a slide valve get out of calibration recently, the computer thought it was at 20% but it was really at 80% or more (im guessing) pulling 800 amps sounded terrible!
Carry over
The works
Good luck!

Theboy
12-03-2014, 07:39 PM
Thanks for all the replys I checked the running pressures and they were all ok oil was also ok running amps were pulling about 49a on each phase have got a more experienced engineer coming to site now just trying to gain as much knowledge as I can for when we go back so I can check everything so thanks for all your suggestions.

Steve186
17-03-2014, 01:03 AM
The boy

without the model of the chiller it's hard to assist you mate
I suspect you are working on a York ycas if so then running at 49amps per phase you are not running at 100%fla I suspect the cause of the screeching is due to running at low load for long periods causing oil return problems for me to assist you further I need more details operating pressures,suction discharge and liquid temps,actual amps,entering and leaving water temp,oil delta p across oil filter ,oil pressure

ESKIM
17-03-2014, 10:27 AM
Dear friends, I have a problem with low outlet temperature of the liquid chillers York ynws.Alarm is "leaving chilled liquid-low temperatures." Setpoint is -6 C compressor and the temperature dropped to -7.6 C and stops working .. The temperature is then not lifted so that the compressor does not automatically move to work a long time.

TF12
17-03-2014, 03:15 PM
1st that should be an auto restart condition.
It just means your machine is cooling the water too fast and it's dropping out and probably won't come back on for 20 minutes.
Do you have a hot gas by pass? Is it working? If it is what are the parameters?
Also you may want to look back in the engine room log to see when the slide valve and volume controls were last calibrated.
Your screw may be out of calibration causing more capacity than what the computer is calling for.

ESKIM
17-03-2014, 08:40 PM
Chillers installed in 2005, and has only 6,000 jobs hours.Hot gas does not exist on the by-pass. Some servicer have done the first service and thereafter chillers is not working normally. Masters maintenance saying that chillers are 15 minutes, the set temperature, frees up to 15% capacity and then goes out and expel mistake leaving chiller liquid-low temperature.Chiller working on a system -10 c.