PDA

View Full Version : AMCOR HD320H Dehumifier - clanging / rattling compressor then Klixon trips







TimUK
11-11-2013, 06:00 PM
I am pleased to find this forum and learn a little about refrigeration as I figure-out if my Amcor HD320H dehumidifier is fixable.

Out of the blue it started to clang and rattle loudly. I have identified that the blower fan is working fine.

Attached to the compressor I have identified a Murata positive temp coefficient (PTC) motor starter thermistor and a 'Klixon' thermal trip. On powering-on the machine it runs for some seconds; sometimes quietly but generally rattling a bit than it used to. Then I hear a click, probably the Klixon device, and it shuts down.

The compressor is labelled:
TATUNG Co. R134a
FH300Y2-E

Sparse detail I know but is this enough information to identify a repairable prospect?

10907

chemi-cool
11-11-2013, 07:13 PM
The company doe's exist for many years, someone must have bought the brand name, product most probably made in china [ low quality]

Compressor is chinese by model no. from your description, it sounds as the compressor is on its way to compressors heaven.
Check with a fridgy the cost of replacing it. a new dehumidifier might cost just as much as the cost of replacing the compressor.

TimUK
12-11-2013, 02:23 PM
Thanks, so it seems that the fault isn't one lf the devices plugged into the side of the compressor; the Klixon and the thermistor.

Oh dear, it's off to the junkyard with it. Bathrooms just aren't as warm and cozy without a dehumidifier so I'd best get shopping for a new one.

TimUK
12-11-2013, 05:04 PM
Ah! I just found that if the unit is tilted about 30 degrees off the vertical the compressor ceases its rattling. I may be able to squeeze a little longer out of this machine. I'll quite likely find the extracted condensate no longer falls into the water carrier - I am expecting a wet floor sometime soon.