PDA

View Full Version : Site Glass Flashing







jakb21599
30-03-2013, 01:03 PM
I ran across a meat case today that i noticed the site glass would be full and no bubbles for a while and then liquid would disappear for 2 or 3 minutes and start back flowing. The owner said he has never had problems with it. The reciever liquid level is right at 80 percent full. So i dont think it is low on charge.. I have not put gauges on it, because he said he has never had a problem with it.
My question is this......What are some things that would cause the site glass to do that?
Will it harm the unit ? What do i look for to find out whats causing it and to fix it ?

Tesla
30-03-2013, 01:19 PM
Hi jakb
Have you searched the search function on this forum - the sightglass has been done recently, check it out.

jakb21599
30-03-2013, 05:12 PM
Hi jakb
Have you searched the search function on this forum - the sightglass has been done recently, check it out.

I did but didn't see what I was looking for.... can you send a link to it ? I checked SC and it is 7 degrees and SH is 31 degrees..... the evaporator SH is 4 degrees which tells me its flooding the evaporator....... would that cause what I am seeing at the site glass ? Its 404A ***** if it matters

Coorsman777
01-04-2013, 01:19 PM
It is possible that the pressure in the receiver gets too low.

jakb21599
01-04-2013, 01:45 PM
It is possible that the pressure in the receiver gets too low.

What would cause that ? And how do you fix it ? I did notice it has a 5/8 liquid line and total run on line set is probably 80 feet and its pulling 3 different cases

1mikeefc1
01-04-2013, 02:35 PM
Is it possible that all the systems are calling for cooling at the same time?

jakb21599
01-04-2013, 03:39 PM
Is it possible that all the systems are calling for cooling at the same time?

Yes...all are hooked to the same unit . Would that cause it ? And why ?

1mikeefc1
01-04-2013, 08:05 PM
Well in theory I suppose it shouldn't but if all the cabinets are calling for refrigeration at the same time it could cause the sight glass to look empty but as they satisfy at different times the level could alter according to how much is needed. Not 100 percent just throwing an idea out there.

Coorsman777
01-04-2013, 08:25 PM
Was thinking this was on a rack system. Sometime if the receiver pressurization is not set right liquid will not get pushed out of the receiver but rather almost pulled out to the txv's.