PDA

View Full Version : screw compressor oil coolers







RANGER1
06-12-2012, 09:52 AM
After peoples advice or opinions on this one.

If you have a number of screw compressors on thermosyphon oil coolers, what would you expect if the oil flow was reduced through one or two of these packages, say worn oil pump.

The oil circuit is basic with no AMOT type valves

oil seperator,oil filter,oil pump, R/S A4AL oil pressure regulating valve returning excess oil pressure to oil seperator,oil cooler, final oil filter then into compressor.

So if you reduce oil flow & oil pressure into compressor would you expect any change in oil or discharge temp?

HVACRsaurus
06-12-2012, 11:24 AM
At a guess I'd say that the oil temperature leaving the thermosyphon may be reasonable, but with a higher discharge / seperator / oil inlet temperature due to dreceased injection quantity... However, I have a sneaking suspicion that the reality could be quite unexpected?

cricri
06-12-2012, 05:48 PM
Hi Ranger,

if you reduce the oil flow into the oil cooler you'll reduce it's efficiency, so the oil temperature at the outlet will increase a few.
Most of the compressors are fitted with a nozzle or a regulating valve at the oil inlet to the rotors, if the oil pressure decreases then the oil flow decreases also and the discharge température increases.
the last effect is if there is less oil cooled returning to the oil separatoir the oil temperature will increase at the inlet of the oil cooler....and the circle is complete!
this could be your problem...or oil in the thermosyphon

Magoo
06-12-2012, 07:53 PM
Hi Ranger1.
probably slightly lower entering oil temps entering compressor and higher than usual discharge temps.
I have had to re-kit several R/S A4AL regulators in the past , gave symptoms you described.
Closely check pre-pump screen filters.

RANGER1
06-12-2012, 08:30 PM
Thanks for replies, It is interesting to me as oil pressure is still acceptable as otherwise it would trip on low oil pressure. So really suuggesting oil flow is down because oil pressure is lower than our normal setting.
Its a Mycom screw running with 250kpa oil pressure, normally we run 300 to 350 kpa.

In this case thermosyphon oil temp goes fron design temp of 45 deg C to 55 deg C & discharge from 79 to 87 deg C.
We usually oversize oil cooler as wellby about 20%.

Oil in/out of cooler still approx 30 deg.
Never seen it before, usually symptom just low oil pressure not much else.
Thought I would have seen it before with blocked oil filters etc etc

Suspected problem worn oil pump!

I guess we could lower oil pressure trip point & open up oil injection in the mean time.

Magoo
06-12-2012, 10:53 PM
Hi Ranger1,
the pre pump screen filters, the low micron screens can look OK but can create low flow to pump. Water blast the screen and dry and replace. Can make a huge difference to pressure and flow rates. OK opening the injection will lower the discharge temp, in the interum.

RANGER1
07-12-2012, 02:26 AM
Hi Ranger1,
the pre pump screen filters, the low micron screens can look OK but can create low flow to pump. Water blast the screen and dry and replace. Can make a huge difference to pressure and flow rates. OK opening the injection will lower the discharge temp, in the interum.

Thanks Magoo,
Hopefully our guys have done that as they are Grasso cleanable pre filters, very fine micron.

Magoo
07-12-2012, 02:55 AM
Hi Ranger1
as they say "been there done that "senario, take them out wash them and hold up to a light all looks good. NOT, water blast the screens out surprising how much gunk comes out.