PDA

View Full Version : chiller frick







serviceman
08-06-2012, 09:47 PM
hy guys:

I have a system of ammonia chiller operating as the plate heat exchanger is flooded with ammonia. my question is: because at a low suction pressure (30psig) if the water temperature is 9 c? thanks

Magoo
09-06-2012, 03:39 AM
At 30psig, evaporating around -9.0 'c , split too big, suggest checking water flow rates too high, alternatively evap HX is not fully flooded. Suction strainer partially blocked.
More system information would help.

Grizzly
09-06-2012, 09:45 AM
Hi Magoo.
If I am correct, the system serviceman may be referring to is similar to the Sabroe packs.
If that is indeed the case, then I would be checking as you say the flow rate of the water through the PHE.

Also the charge level as they tend to struggle if the level is not suffice.
This is, as I suggest. Dependant upon what Serviceman is dealing with.
Grizzly

cricri
09-06-2012, 06:14 PM
You should try to drain the oil from your PHE. probably something wrong with your oil return

serviceman
11-06-2012, 03:50 PM
I'll upload some pictures of the system in a while to see what I can support. thanks

serviceman
11-06-2012, 07:39 PM
Ammonia is a system that cools water, we have 03 compressors RXF-39 with 125hp engine, use water to cool edible soybean oil, water must go back to 8 C and 12 . thanks

serviceman
11-06-2012, 10:22 PM
this day so the machine was operating ps = 49psig ts = 5.3 c tchw = 9.2 c dp = 161 psig dt = 58.2 c % = 47.1% compressor 717 refrigerant