PDA

View Full Version : FRICK RWB II Plus Main Board







Tung
18-11-2011, 05:52 PM
Hello gentlemen:
has anybody ever heard the LSI compay in Waynesboro,
they declare themselves the OEM of RWB II Plus main board,
thanks for your help!

CanadianIce
19-11-2011, 03:14 AM
I have purchased several boards from them. I have also had a couple of them fail quickly.

Tung
19-11-2011, 04:21 AM
thanks for your reply,
is the failure rate high?
the thing I would care is, is this board really available?

Tung

CanadianIce
27-11-2011, 06:54 PM
The failure rate isn't high. They have always had boards available when I needed one.

ref79
28-11-2011, 08:55 AM
the board are really good from frick i do not see any failure unless and untill they are wrongly installed and operated.

CanadianIce
28-11-2011, 10:44 PM
The boards I got from them were remanufactured.

Tung
04-12-2011, 06:15 PM
Sorry for replying late,
just finished an overhaul job for a York K3 centrifugal compressor and came back from Vietnam last Fri,
I will purchase boards from LSI,
thanks for the information.

Tung
17-02-2012, 03:16 PM
got problem when replacing the board by new board from LSI,
the OP and Discharge pressure readings are incorrect,
then I found on the original board the power supply to transducer is 15 VDC,
while on the new board is 12 VDc,
the staff in LSI told me the have made some improvement to the new board,
and the difference on VDC supply(+12 or +15) will not be the reason for the faulty condition,
have you guys ever experienced such problem?
if you have, please advise your solution, thanks in advance.

Magoo
17-02-2012, 10:53 PM
You will have to re-calibrate all the transducers, its been a while since I have done it. Basically power off the system and disconnect all transducers to atmosphere pressure, then repower the PCB so it zeros itself then reconnect all transducers. The procedure is in the manual.
Effectively the transducers are a strain gauge and the voltage output reacst accordingly, so change the voltage input and the output will change proportionally. Thats why some displays are screwy

Tung
21-02-2012, 02:10 PM
As this is a YS S7 chiller using RWB II Plus control center, the working range of transducers are different from those Frick refrigeration unit,
I supplied 15 VDC to Suct(025-28955-002), Discharge, Oil and Filter(025-28955-001) transducers, the feedback signals can match the current pressure in the refrigerant system, for the Dis, Oil and Filter transducers, the readings are correct(100Psi), but the Suct pressure reading is only 40 Psig, which is 60 Psi below what is supposed to, then I am quite confused, as I mentioned, the feedback signal from suct transducer is 3.2 VDC, comparing to the converting table in York manual 160.65-OM1, the pressure reading should be 100 Psi,
I replaced the Prom U4 and U5 copied from another YS chiller and I got same result,
don't know what is wrong, and don't have any idea for further step,
can anybody help? I will be much appreciated.