PDA

View Full Version : Oil separator clean up after screw failure?







kiwi
24-06-2010, 10:25 PM
Hello, I have a Frick (RWB270) package with a screw compressor that has run out of oil and died a very messy death. I now have a lot of metal through the skid especially the oil separator. As these are pretty well sealed I was trying to come up with a plan to try and flush as much of the debris out. I have taken out a probe pocket as well as the oil pump connection but there is not much access into the separator. I had considered cutting into it but that opens up a whole new can of worms with re-certification etc of the vessel. The oil has also been pretty burnt so there will be a carbon "crust" on the internals at a guess. Any suggestions on solvents etc to flush out with. I am in New Zealand so some products could not be available here.
By the way this is a lemon I inherited and it sure did not smoke itself under my watch! :D
Cheers, Kiwi

Superfridge
01-07-2010, 09:20 AM
I have heard of Tergosol being pumped through a separator before, worked too. You will need to fill the separator to above normal oil level.
If you pumped it through a flanged fitting on the discharge all the lines could be flushed out. Can be strained and then recirculated.

Hope this helps.

Why did it run out of oil?

Fri3Oil System
02-07-2010, 07:05 AM
Hi,

I`m sure our cleaning system would help. You wouldn't need to use any solvent, just flushing/recirculating R22 for instance.

We have no clients in NZ yet and I am not sure if it would be worth it to buy it just for one job.

Using solvents will be just adding more dirt into the circuit that will be hard to remove afterwards.

Regards,

Nando

lowcool
03-07-2010, 03:07 AM
how the fark did dirt get in the system?

sterl
03-07-2010, 03:51 PM
What refrigerant and lubricant are you on?

If this is R-22 and you are trying to clean up a 30" Oil Sep (which I thing is correct for the 270 package...) you are going to need to be able to charge with a considerable volume of solvent; recirculate it pretty fast to move the heavier particles; and seoarate the metal at least while the circulation continues.

The last effort I had with something like this involved: 5-drums of solvent you can't buy anymore; a metal trash pail; a homemade electomagent cluster made out of a batch of big solenoid cols and iron bolts; a throwaway sump pump at about 40 gpm; and a big plastic pan that got eaten up by the solvent. Miscellaneous hoses; a lot of ventilation; a bounc of funels; a barrel pump and so on...

But you get the picture....Its a load of temporary set up; and the solvent is literally poured to both sides of the separator by the pump discharge.

I took out about 70 lbs of steel fines, vessel slag and similar; and a sediment that was mainly oil coke. The solvent was useless afterward and its disposal process was the worst headache of the entire exercise.

Took a good 2-days to draft out and vacuum out the package and we drained after vacuuming and re-vacced as well. Putting in the oils without evaccing the solvent would have been counterproductive....

Run a few days; change out filters and coalescers and oil; run a few more days; sent oil sample off with specific requirements for analysis and report. Came back good....

Having done it: Could do it faster today but I would have to spend considerable time selecting solvent and following up on its disposal. Rest of the stuff didn't cost much and some of it actually survived.

RANGER1
04-07-2010, 12:07 AM
Have sucessfully used a chemical called MET TANK 43 from Drew chemicals , but don't know if its still available .
Basically call around for a decarbonizing chemical .
As Sterl says a big job .
Drew supplied tank with circulating ( pool ) pump . We had to heat it with insertion heater to 55 C & circulated for 24 hrs through oil cooler and seperator .
They also disposed of chemical when finished .
Added new oil and changed again after 24 hrs .
Expect a few filter changes .

Expensive but what choice do you have ?

kiwi
21-07-2010, 02:55 AM
Thanks for the feedback lads. The new compressor is now on and running.
The refigerant is R717 and we think lost oil cooling not lubrication for extended periods. There was so many broken components on this package it looks like it was running without much feedback and overheated to the point of collapse in the bearings. Those of you who have seen this happen will know the resulting mess left over. I am not 100% happy with the end result as we were unable to do more than basic clean up (client needed compressor operational) so we need to keep an eye on the filters etc and expecting to replace a fare few of them!
Cheers

oldesky
21-07-2010, 04:13 AM
Kiwi, why dont try steelfort or millers in NZ. They may be able to cut it open for you clean it and recertify.

kiwi
21-07-2010, 08:23 AM
Kiwi, why dont try steelfort or millers in NZ. They may be able to cut it open for you clean it and recertify.
Steelfort are not really up to this task and I work for Millers (Realcold) :D
Time constrants did not allow for more than the minimum. So far so good though. Just need to be a bit more regular in checks etc. Oil analysis will be interesting.

piewie
08-08-2010, 03:52 PM
Ammonia is a very good solvent so basically keep changing the oil filters and you should be ok. Diligence being the key to success.