PDA

View Full Version : Problem with centrif - help requested







Brian_UK
17-03-2005, 04:29 PM
I have transferred this post from the Chit-Chat section and hope someone can help 'Energy' from the Phillippines.
Brian
+
Good day,

Can any one help me out with some of the problem we had in the field.

We have a Mc Quay Chiller model PEH 087, the unit is a centrifugal chiller. The impeller and the inlet guide vane just melted.

According to Mc Quay the cause is lubrication failure, however when they tear down the compressor, we inspected the high and low speed gear and the gear teeth did not show any wear. Any Idea what the problem is.

Another unit we have is a JE Hall compressor Model HS 2022, the unit is fitted with a Fridge watch controller, one day the unit micro just wont operate an the LED display just show 0000 (zeros), I dont have any manual of both the unit and the micro controller, the old contractor doing the service may have taken it, can any body help me to figure out what is the problem.

Argus
17-03-2005, 05:07 PM
It's possible that the thrust has failed and sent the inpellor assembly into the wall of the volute, or even the wheel has shifted on the shaft.
It would certainly have got very hot if it melted the metal.... what's the refrigerant like?

I had an instance in the late 70s on a carrier 19 series running on R11 where the wheel came off... made an awful mess, and the thing got so hot the rupture disc blew.
________
BMW E12 (http://www.bmw-tech.org/wiki/BMW_E12)

energy
18-03-2005, 03:48 PM
Thank you for the info, the Mc Quay unit uses R-12,

rbartlett
18-03-2005, 08:58 PM
which one is you??

cheers

richard

Brian_UK
18-03-2005, 10:23 PM
"Hope this helps?"
Nah, no ear defenders Marc ??

Dave Goodings
03-08-2005, 10:31 PM
Nah he just got lost in this plant room!!!
Regards
Dave G