PDA

View Full Version : Lennox KNHK 43E







CoolKids
27-11-2007, 11:04 PM
Hi All

Attended site to complaints of Lennox air cooled unit tripping out.
Checked over found motor protection device stopping compressor.
Bypassed MPD for a short period of time to find the low/high side refrigerant pressures doing hardly nothing.
Also found paint on compressor head to be badly cracked.
Could anyone help me with this problem.

chillin out
27-11-2007, 11:17 PM
Sounds like the compressor is not starting up properly.

Check the capacitors and starting relay.

Then repaint the comp.

Chillin:):)

CoolKids
28-11-2007, 10:25 AM
Chillin Out

The compressor is 3 phase.

No cappys and relays on this one.

CoolKids

PaulZ
28-11-2007, 12:15 PM
CoolKids
I presume this is a semi and from the info it sounds like the compressor has been getting pretty hot.
If there is little difference between suction and discharge I would say the valves are shot and therefore not pumping and very little cold gas coming back to cool the windings causing the thermistor relay to trip.
Pull the compressor out and replace with a new or rebuilt one.
Paul

Grizzly
28-11-2007, 08:34 PM
CoolKids
PaulZ is absolutely correct.
On any recip if there is little or no difference between the suction and discharge pressures.
Then it's a safe bet that the compressor is not compressing the refrigerant vapour. And the first thing to suspect is the valves being worn and no longer being gas tight. Also as a consequence of passing discharge valves. High head temperatures can be experianced (badly cracked paint on the head!)
Also as Paul mentioned, semi hermetic compressors rely on the cooling effect of the suction gases. Flowing through the windings to
cool the motor.
Dependant on wether you or your collegues strip and rebuild these comps?
Will determine your next move.
Grizzlyhttp://www.refrigeration-engineer.com/forums/images/icons/icon14.gif

CoolKids
28-11-2007, 10:29 PM
Grizzly& PaulZ
Thanks for your help.

Cheers

CoolKids